summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2015-05-21 10:47:23 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-05-21 22:56:21 +0200
commit1b1657621668ee8160f896cddc3009fc803b25ee (patch)
tree7917f304e6895d5495fd138d7660c986072e41ea
parentfd25b0128945aa118cb5f66e665d445d0da1d7dd (diff)
package/qemu: Compare host/target Linux version only during build phase
This patch fixes an error during source-check. Thanks to Thomas for the hint: http://article.gmane.org/gmane.comp.lib.uclibc.buildroot/116183 Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--package/qemu/qemu.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/qemu/qemu.mk b/package/qemu/qemu.mk
index 04df79fcd..0620804a0 100644
--- a/package/qemu/qemu.mk
+++ b/package/qemu/qemu.mk
@@ -85,10 +85,12 @@ HOST_QEMU_COMPARE_VERSION = $(shell test $(HOST_QEMU_HOST_SYSTEM_VERSION) -ge $(
# built with kernel headers that are older or the same as the kernel
# version running on the host machine.
#
+ifeq ($(BR_BUILDING),y)
ifneq ($(HOST_QEMU_COMPARE_VERSION),OK)
$(error "Refusing to build qemu-user: target Linux version newer than host's.")
endif
endif
+endif
define HOST_QEMU_CONFIGURE_CMDS
cd $(@D); $(HOST_CONFIGURE_OPTS) ./configure \