summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2013-09-18 10:38:02 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2013-09-18 16:57:14 +0200
commit22718b0e2c1d2b471ef60dc7992ad94376bb48b7 (patch)
tree55610aa954299f391ddb295c6b9efe70af0cae08
parent96ac9ef5be29dee88f24cf583ca8c53be481bb8f (diff)
libiconv: fixup library permissions
libiconv.so* and libcharset.so* are installed without +x permissions thus preventing stripping. Fix it up in the post install target hooks. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/libiconv/libiconv.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/libiconv/libiconv.mk b/package/libiconv/libiconv.mk
index d6a1d6f49..aa6d6de8b 100644
--- a/package/libiconv/libiconv.mk
+++ b/package/libiconv/libiconv.mk
@@ -21,6 +21,14 @@ endef
LIBICONV_POST_INSTALL_TARGET_HOOKS += LIBICONV_TARGET_REMOVE_PRELOADABLE_LIBS
LIBICONV_POST_INSTALL_STAGING_HOOKS += LIBICONV_STAGING_REMOVE_PRELOADABLE_LIBS
+# Library lacks +x so strip skips it
+define LIBICONV_FIX_LIBRARY_MODE
+ -chmod +x $(TARGET_DIR)/usr/lib/libcharset.so*
+ -chmod +x $(TARGET_DIR)/usr/lib/libiconv.so*
+endef
+
+LIBICONV_POST_INSTALL_TARGET_HOOKS += LIBICONV_FIX_LIBRARY_MODE
+
$(eval $(autotools-package))
# Configurations where the toolchain supports locales and the libiconv