summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-12-27 17:25:56 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-12-27 18:46:51 +0100
commit235c95af8fecdcf1326572f47367d9b6d0d55e76 (patch)
tree3c082c44e490ab0986a8b0dd740cfb6d97f2aed5
parent90a6675e18d60e0b077bc316261b7c0ebb773d88 (diff)
xerces: make sure to use the cross-compiled curl
When curl support is enabled in xerces, and a host curl is available on the system, it might try to use it, so this patch adds --with-curl= to the configure options to explicitly indicate where is the curl library to use. Should fix: http://autobuild.buildroot.org/results/c3c/c3c6be45d0f764fb931a46dbf1509ccf2916ecbf/ (We were not able to reproduce specifically this problem, but another similar problem, where curl was detected, but considered as non-working because of the compilation failure of a test program.) Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
-rw-r--r--package/xerces/xerces.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/xerces/xerces.mk b/package/xerces/xerces.mk
index 36955e367..9b2bb81ec 100644
--- a/package/xerces/xerces.mk
+++ b/package/xerces/xerces.mk
@@ -20,7 +20,7 @@ XERCES_DEPENDENCIES += libiconv
endif
ifeq ($(BR2_PACKAGE_LIBCURL),y)
-XERCES_CONF_OPTS += --enable-netaccessor-curl
+XERCES_CONF_OPTS += --enable-netaccessor-curl --with-curl=$(STAGING_DIR)/usr/lib
XERCES_DEPENDENCIES += libcurl
else
XERCES_CONF_OPTS += --disable-network