summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2014-12-23 18:46:36 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-12-27 19:58:29 +0100
commit25dc51caef0b3b46e1d36f8dedcf53e29ba3d53a (patch)
tree998e3783e7138e6c2275c47e8c89eb6ed8c3f9dd
parent7881cbc295a96568b224b5cdb85ea0211972358e (diff)
package/kodi: New option to enable support for optical drives
This also enables dvdcss support, provided by an internal library. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--package/kodi/Config.in5
-rw-r--r--package/kodi/kodi.mk7
2 files changed, 11 insertions, 1 deletions
diff --git a/package/kodi/Config.in b/package/kodi/Config.in
index 4bc017873..22060b186 100644
--- a/package/kodi/Config.in
+++ b/package/kodi/Config.in
@@ -235,6 +235,11 @@ config BR2_PACKAGE_KODI_WAVPACK
Enable WAV input support.
Select this if you want to play back WV files.
+config BR2_PACKAGE_KODI_OPTICALDRIVE
+ bool "optical drive"
+ help
+ Enable support for optical drives
+
comment "Kodi addons"
source "package/kodi-addon-xvdr/Config.in"
diff --git a/package/kodi/kodi.mk b/package/kodi/kodi.mk
index 14fa2445c..cd1f2fb54 100644
--- a/package/kodi/kodi.mk
+++ b/package/kodi/kodi.mk
@@ -37,7 +37,6 @@ KODI_CONF_OPTS += \
--disable-joystick \
--disable-mysql \
--disable-openmax \
- --disable-optical-drive \
--disable-projectm \
--disable-pulse \
--disable-ssh \
@@ -189,6 +188,12 @@ else
KODI_CONF_OPTS += --disable-vaapi
endif
+ifeq ($(BR2_PACKAGE_KODI_OPTICALDRIVE),y)
+KODI_CONF_OPTS += --enable-optical-drive --enable-dvdcss
+else
+KODI_CONF_OPTS += --disable-optical-drive --disable-dvdcss
+endif
+
# Add HOST_DIR to PATH for codegenerator.mk to find swig
define KODI_BOOTSTRAP
cd $(@D) && PATH=$(BR_PATH) ./bootstrap