summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas De Schampheleire <patrickdepinguin@gmail.com>2014-02-05 10:44:00 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-02-05 12:09:35 +0100
commit3880a6ab3ca3890e79a7a429a58903217f36770d (patch)
treef275f787ddac92a4e3817b99a58816b43016cde6
parente7ab4b49f4dd16a1312db3144376f26d4340e15e (diff)
infra: remove redundant $(call) on pkgdir, pkgname, pkgparentdir
When calling make 'functions', the $(call) keyword is only needed if the function takes arguments. For pkgdir, pkgname and pkgparentdir this is not the case, so we can remove the call to make things more readable. Suggested-by: Arnout Vandecappelle <arnout@mind.be> Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
-rw-r--r--package/pkg-autotools.mk4
-rw-r--r--package/pkg-cmake.mk4
-rw-r--r--package/pkg-generic.mk4
-rw-r--r--package/pkg-luarocks.mk2
-rw-r--r--package/pkg-python.mk4
-rw-r--r--package/pkg-utils.mk4
6 files changed, 11 insertions, 11 deletions
diff --git a/package/pkg-autotools.mk b/package/pkg-autotools.mk
index a66ecd414..0ddfc6be0 100644
--- a/package/pkg-autotools.mk
+++ b/package/pkg-autotools.mk
@@ -275,5 +275,5 @@ endef
# autotools-package -- the target generator macro for autotools packages
################################################################################
-autotools-package = $(call inner-autotools-package,$(call pkgname),$(call UPPERCASE,$(call pkgname)),$(call UPPERCASE,$(call pkgname)),$(call pkgparentdir),target)
-host-autotools-package = $(call inner-autotools-package,host-$(call pkgname),$(call UPPERCASE,host-$(call pkgname)),$(call UPPERCASE,$(call pkgname)),$(call pkgparentdir),host)
+autotools-package = $(call inner-autotools-package,$(pkgname),$(call UPPERCASE,$(pkgname)),$(call UPPERCASE,$(pkgname)),$(pkgparentdir),target)
+host-autotools-package = $(call inner-autotools-package,host-$(pkgname),$(call UPPERCASE,host-$(pkgname)),$(call UPPERCASE,$(pkgname)),$(pkgparentdir),host)
diff --git a/package/pkg-cmake.mk b/package/pkg-cmake.mk
index 13be5570c..36283f07c 100644
--- a/package/pkg-cmake.mk
+++ b/package/pkg-cmake.mk
@@ -150,8 +150,8 @@ endef
# cmake-package -- the target generator macro for CMake packages
################################################################################
-cmake-package = $(call inner-cmake-package,$(call pkgname),$(call UPPERCASE,$(call pkgname)),$(call UPPERCASE,$(call pkgname)),$(call pkgparentdir),target)
-host-cmake-package = $(call inner-cmake-package,host-$(call pkgname),$(call UPPERCASE,host-$(call pkgname)),$(call UPPERCASE,$(call pkgname)),$(call pkgparentdir),host)
+cmake-package = $(call inner-cmake-package,$(pkgname),$(call UPPERCASE,$(pkgname)),$(call UPPERCASE,$(pkgname)),$(pkgparentdir),target)
+host-cmake-package = $(call inner-cmake-package,host-$(pkgname),$(call UPPERCASE,host-$(pkgname)),$(call UPPERCASE,$(pkgname)),$(pkgparentdir),host)
################################################################################
# Generation of the CMake toolchain file
diff --git a/package/pkg-generic.mk b/package/pkg-generic.mk
index 1b99c2a25..eea530f2a 100644
--- a/package/pkg-generic.mk
+++ b/package/pkg-generic.mk
@@ -617,8 +617,8 @@ endef # inner-generic-package
################################################################################
# In the case of target packages, keep the package name "pkg"
-generic-package = $(call inner-generic-package,$(call pkgname),$(call UPPERCASE,$(call pkgname)),$(call UPPERCASE,$(call pkgname)),$(call pkgparentdir),target)
+generic-package = $(call inner-generic-package,$(pkgname),$(call UPPERCASE,$(pkgname)),$(call UPPERCASE,$(pkgname)),$(pkgparentdir),target)
# In the case of host packages, turn the package name "pkg" into "host-pkg"
-host-generic-package = $(call inner-generic-package,host-$(call pkgname),$(call UPPERCASE,host-$(call pkgname)),$(call UPPERCASE,$(call pkgname)),$(call pkgparentdir),host)
+host-generic-package = $(call inner-generic-package,host-$(pkgname),$(call UPPERCASE,host-$(pkgname)),$(call UPPERCASE,$(pkgname)),$(pkgparentdir),host)
# :mode=makefile:
diff --git a/package/pkg-luarocks.mk b/package/pkg-luarocks.mk
index e82818a0c..fdd26c750 100644
--- a/package/pkg-luarocks.mk
+++ b/package/pkg-luarocks.mk
@@ -78,5 +78,5 @@ endef
# luarocks-package -- the target generator macro for LuaRocks packages
################################################################################
-luarocks-package = $(call inner-luarocks-package,$(call pkgname),$(call UPPERCASE,$(call pkgname)),$(call UPPERCASE,$(call pkgname)),$(call pkgparentdir),target)
+luarocks-package = $(call inner-luarocks-package,$(pkgname),$(call UPPERCASE,$(pkgname)),$(call UPPERCASE,$(pkgname)),$(pkgparentdir),target)
# host-luarocks-package not supported
diff --git a/package/pkg-python.mk b/package/pkg-python.mk
index 79e6bcfa6..9cfd8200f 100644
--- a/package/pkg-python.mk
+++ b/package/pkg-python.mk
@@ -220,5 +220,5 @@ endef
# python-package -- the target generator macro for Python packages
################################################################################
-python-package = $(call inner-python-package,$(call pkgname),$(call UPPERCASE,$(call pkgname)),$(call UPPERCASE,$(call pkgname)),$(call pkgparentdir),target)
-host-python-package = $(call inner-python-package,host-$(call pkgname),$(call UPPERCASE,host-$(call pkgname)),$(call UPPERCASE,$(call pkgname)),$(call pkgparentdir),host)
+python-package = $(call inner-python-package,$(pkgname),$(call UPPERCASE,$(pkgname)),$(call UPPERCASE,$(pkgname)),$(pkgparentdir),target)
+host-python-package = $(call inner-python-package,host-$(pkgname),$(call UPPERCASE,host-$(pkgname)),$(call UPPERCASE,$(pkgname)),$(pkgparentdir),host)
diff --git a/package/pkg-utils.mk b/package/pkg-utils.mk
index 851575c54..51dd7384b 100644
--- a/package/pkg-utils.mk
+++ b/package/pkg-utils.mk
@@ -59,8 +59,8 @@ endef
# pkgdir macro is carefully written to handle the case of the Linux
# package, for which the package directory is an empty string.
pkgdir = $(dir $(lastword $(MAKEFILE_LIST)))
-pkgname = $(lastword $(subst /, ,$(call pkgdir)))
-pkgparentdir = $(patsubst %$(call pkgname)/,%,$(call pkgdir))
+pkgname = $(lastword $(subst /, ,$(pkgdir)))
+pkgparentdir = $(patsubst %$(pkgname)/,%,$(pkgdir))
# Define extractors for different archive suffixes
INFLATE.bz2 = $(BZCAT)