summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Brodkin <Alexey.Brodkin@synopsys.com>2015-08-10 16:36:36 +0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-08-10 15:42:25 +0200
commit38ea889ed07b29bd68b17b2629869588b27536e8 (patch)
tree95b41fec8521084a52bedf9a551551471323de07
parent9c635f86d84bfc915a6dd8928f15082f302a9986 (diff)
tinc: disable PIE on ARC
Even though ARC gcc understands "-pie" option and attempts to generate PIE binaries as of today PIE is not really supported for user-space applications. So we disable PIE detection if building for ARC. That fixes http://autobuild.buildroot.net/results/2b1/2b1aa474fc432f3f79b03c4577d68642bb7e0f9c and also prevents execution of non-supported PIE binary in runtime. [Thomas: fix indentation.] Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--package/tinc/tinc.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/tinc/tinc.mk b/package/tinc/tinc.mk
index b8d4ca77e..f7edd79ac 100644
--- a/package/tinc/tinc.mk
+++ b/package/tinc/tinc.mk
@@ -11,4 +11,10 @@ TINC_LICENSE = GPLv2+ with OpenSSL exception
TINC_LICENSE_FILES = COPYING COPYING.README
TINC_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -std=c99"
+ifeq ($(BR2_arc),y)
+TINC_CONF_ENV += \
+ ax_cv_check_cflags___fPIE=no \
+ ax_cv_check_ldflags___pie=no
+endif
+
$(eval $(autotools-package))