summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaruch Siach <baruch@tkos.co.il>2015-02-26 20:41:26 +0200
committerPeter Korsgaard <peter@korsgaard.com>2015-02-26 23:25:03 +0100
commit38ee8a8e1651f1de2b2698e4c6bce2e488001cdb (patch)
treecca9f22619ecacb24250f61da0e8e40b7cd19bd9
parent5d156559648ae24571f9fbfd5103928fa4177616 (diff)
make: depend on guile explicitly when available
Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
-rw-r--r--package/make/make.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/make/make.mk b/package/make/make.mk
index d643fb000..6e7a8f1ae 100644
--- a/package/make/make.mk
+++ b/package/make/make.mk
@@ -16,4 +16,11 @@ ifeq ($(BR2_STATIC_LIBS),y)
MAKE_CONF_OPTS += --disable-load
endif
+ifeq ($(BR2_PACKAGE_GUILE),y)
+MAKE_DEPENDENCIES += guile
+MAKE_CONF_OPTS += --with-guile
+else
+MAKE_CONF_OPTS += --without-guile
+endif
+
$(eval $(autotools-package))