summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2016-01-30 17:17:16 +0100
committerPeter Korsgaard <peter@korsgaard.com>2016-01-31 14:26:03 +0100
commit40353e3e13e9b1c7ad95237fbc745f914bfa50ad (patch)
treeca87c2c334ee17a457d33d88df78e2ccb27f8023
parent96f06290a5914eb683d1f4fb40f9ed1d125b294f (diff)
package/libraw: add optional support for lcms2
[Peter: also needs host-pkgconf] Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
-rw-r--r--package/libraw/libraw.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/package/libraw/libraw.mk b/package/libraw/libraw.mk
index 5ebc4a2de..03f09f96f 100644
--- a/package/libraw/libraw.mk
+++ b/package/libraw/libraw.mk
@@ -12,7 +12,6 @@ LIBRAW_INSTALL_STAGING = YES
LIBRAW_AUTORECONF = YES
LIBRAW_CONF_OPTS += \
--disable-examples \
- --disable-lcms \
--disable-openmp \
--disable-demosaic-pack-gpl2 \
--disable-demosaic-pack-gpl3
@@ -33,4 +32,11 @@ else
LIBRAW_CONF_OPTS += --disable-jpeg
endif
+ifeq ($(BR2_PACKAGE_LCMS2),y)
+LIBRAW_CONF_OPTS += --enable-lcms
+LIBRAW_DEPENDENCIES += lcms2 host-pkgconf
+else
+LIBRAW_CONF_OPTS += --disable-lcms
+endif
+
$(eval $(autotools-package))