summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2015-05-16 22:57:37 +0200
committerPeter Korsgaard <peter@korsgaard.com>2015-05-16 23:00:47 +0200
commit5504039c4e42ef9fc2b0b5c199f859da6930c9cc (patch)
treed5d12c4315c6af4e1f0f2cef68098e98352d4f18
parent1a0986d6da65719fb8e0da55c1a6598cb99b620e (diff)
neardal: fix readline/libedit detection with static linking
Fixes: http://autobuild.buildroot.net/results/c3e/c3ea67d9b341749b9591451da3f3b0cb4a9fbb74/ http://autobuild.buildroot.net/results/586/586fa95149aa37df7ef430e3a47a3418e6f7ed97/ http://autobuild.buildroot.net/results/3ea/3eabd3a2cea0d5863b1c0dd8f55c73f34a684f79/ Both readline and libedit link with ncurses but the configure script forgets to take that into account, causing the detection to fail when linking statically. Fix it by using pkg-config to add the needed linker options for ncurses. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
-rw-r--r--package/neardal/neardal.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/neardal/neardal.mk b/package/neardal/neardal.mk
index 382c42e10..c65a5e616 100644
--- a/package/neardal/neardal.mk
+++ b/package/neardal/neardal.mk
@@ -21,6 +21,13 @@ else ifeq ($(BR2_PACKAGE_LIBEDIT),y)
NEARDAL_DEPENDENCIES += libedit
endif
+# Both readline and libedit link with ncurses but the configure script
+# forgets to take that into account, causing the detection to fail
+# when linking statically
+ifeq ($(BR2_STATIC_LIBS),y)
+NEARDAL_CONF_ENV += LIBS=$(shell $(PKG_CONFIG_HOST_BINARY) --libs ncurses)
+endif
+
define NEARDAL_INSTALL_NCL
$(INSTALL) -m 0755 -D $(@D)/ncl/ncl $(TARGET_DIR)/usr/bin/ncl
endef