summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Seiderer <ps.report@gmx.net>2015-10-03 20:44:12 +0100
committerPeter Korsgaard <peter@korsgaard.com>2015-10-04 20:17:35 +0200
commit5774f07d43c8694b9640e67db771676af07c430b (patch)
treeaacfd7de1f0d54716ddde46ed1bbc184d6f71118
parentab74e09eb4e28dab8bed8d783c5f0464d39a32e7 (diff)
dtc: add host build
Having a host variant of dtc is needed for example for U-Boot, which uses the Device Tree for a number of platforms. In addition, now that we have a proper host-dtc package, it is no longer needed for the linux package to install the host dtc compiler: users interested in having the host dtc compiler can simply enable this package. A Config.in.host option is added to build host-dtc, because the initial reason why the host DTC built by the kernel was installed in $(HOST_DIR)/usr/bin (commit 707d44d0a28906ebda49584dd5f55985406f0bde from Thomas DS) was: Having dtc as a host tool can be useful for users that have a custom boot scenario where the device tree is not embedded in the kernel. [Thomas: - rework the commit log.] [Peter: keep the (renamed) linux version] Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
-rw-r--r--package/Config.in.host1
-rw-r--r--package/dtc/Config.in.host9
-rw-r--r--package/dtc/dtc.mk10
3 files changed, 20 insertions, 0 deletions
diff --git a/package/Config.in.host b/package/Config.in.host
index 1e047aadf..1f69687b3 100644
--- a/package/Config.in.host
+++ b/package/Config.in.host
@@ -5,6 +5,7 @@ menu "Host utilities"
source "package/dfu-util/Config.in.host"
source "package/dos2unix/Config.in.host"
source "package/dosfstools/Config.in.host"
+ source "package/dtc/Config.in.host"
source "package/e2fsprogs/Config.in.host"
source "package/e2tools/Config.in.host"
source "package/faketime/Config.in.host"
diff --git a/package/dtc/Config.in.host b/package/dtc/Config.in.host
new file mode 100644
index 000000000..cbabf0a24
--- /dev/null
+++ b/package/dtc/Config.in.host
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_HOST_DTC
+ bool "host dtc"
+ help
+ The Device Tree Compiler, dtc, takes as input a device-tree in
+ a given format and outputs a device-tree in another format.
+
+ Install host tools: dtc, convert-dtsv0, fdtdump, fdtget and fdtput.
+
+ https://git.kernel.org/cgit/utils/dtc/dtc.git
diff --git a/package/dtc/dtc.mk b/package/dtc/dtc.mk
index e094f7bf7..f3b6f3b54 100644
--- a/package/dtc/dtc.mk
+++ b/package/dtc/dtc.mk
@@ -44,4 +44,14 @@ define DTC_INSTALL_TARGET_CMDS
$(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) PREFIX=/usr $(DTC_INSTALL_GOAL)
endef
+# host build
+define HOST_DTC_BUILD_CMDS
+ $(HOST_CONFIGURE_OPTS) $(MAKE) -C $(@D) PREFIX=$(HOST_DIR)/usr
+endef
+
+define HOST_DTC_INSTALL_CMDS
+ $(MAKE) -C $(@D) PREFIX=$(HOST_DIR)/usr install-bin
+endef
+
$(eval $(generic-package))
+$(eval $(host-generic-package))