summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Krause <joerg.krause@embedded.rocks>2016-04-29 09:56:58 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-05-01 22:36:29 +0200
commit5a61c2cc775263ba7c4814b92d35b923ad0617a0 (patch)
tree5283c3fdf25873afe7f5042152b5f6289d2215cc
parent34130233023233ab8c59df38af9c9771fa706902 (diff)
mtd: install header files to staging directory
These header files are required by swupdate. Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--package/mtd/mtd.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/mtd/mtd.mk b/package/mtd/mtd.mk
index adbf28d8f..bf90212f5 100644
--- a/package/mtd/mtd.mk
+++ b/package/mtd/mtd.mk
@@ -107,6 +107,9 @@ endef
define MTD_INSTALL_STAGING_CMDS
$(INSTALL) -D -m 0755 $(@D)/lib/libmtd.a $(STAGING_DIR)/usr/lib/libmtd.a
$(INSTALL) -D -m 0755 $(@D)/ubi-utils/libubi.a $(STAGING_DIR)/usr/lib/libubi.a
+ $(INSTALL) -D -m 0644 $(@D)/include/libmtd.h $(STAGING_DIR)/usr/include/mtd/libmtd.h
+ $(INSTALL) -D -m 0644 $(@D)/ubi-utils/include/libubi.h $(STAGING_DIR)/usr/include/mtd/libubi.h
+ $(INSTALL) -D -m 0644 $(@D)/include/mtd/ubi-media.h $(STAGING_DIR)/usr/include/mtd/ubi-media.h
endef
define MTD_INSTALL_TARGET_CMDS