summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2016-02-21 18:34:54 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-21 21:27:23 +0100
commit63311a52c8e8353596bc5525b6f5122271e96435 (patch)
treebf84f03628cd186e7a248c2790ac22d9ffdd0fe9
parent97e86eff5ae9fd4713a564e3168539068b856e41 (diff)
package/mediastreamer: add optional support for opus
When opus was compiled before, mediastreamer will use it as optional dependency: $ output/host/usr/bin/x86_64-linux-readelf -a output/target/usr/lib/libmediastreamer_voip.so.3.0.0 | grep NEEDED 0x0000000000000001 (NEEDED) Shared library: [libmediastreamer_base.so.3] 0x0000000000000001 (NEEDED) Shared library: [libopus.so.0] [...] Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--package/mediastreamer/mediastreamer.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/mediastreamer/mediastreamer.mk b/package/mediastreamer/mediastreamer.mk
index 047509ee5..cf2519668 100644
--- a/package/mediastreamer/mediastreamer.mk
+++ b/package/mediastreamer/mediastreamer.mk
@@ -27,6 +27,13 @@ else
MEDIASTREAMER_CONF_OPTS += --disable-upnp
endif
+ifeq ($(BR2_PACKAGE_OPUS),y)
+MEDIASTREAMER_CONF_OPTS += --enable-opus
+MEDIASTREAMER_DEPENDENCIES += opus
+else
+MEDIASTREAMER_CONF_OPTS += --disable-opus
+endif
+
# portaudio backend needs speex as well
ifeq ($(BR2_PACKAGE_PORTAUDIO)$(BR2_PACKAGE_SPEEX),yy)
MEDIASTREAMER_CONF_OPTS += --enable-portaudio