summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Raeman <draeman@bbn.com>2016-07-25 15:52:26 -0400
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-07-25 23:46:19 +0200
commit6f8162cf8c1abef7e0a4771fe0d6b26a28f5c2b6 (patch)
tree20c38ce8e1358d58df44838c3f6384f29da3be78
parent67f96915b14a3f316ee1850253fc7ce11982fafb (diff)
package/Makefile.in should grab HOST_DIR headers using -isystem instead of -I.
HOST_CFLAGS includes a search path for HOST_DIR/usr/include using -I. When HOST_CFLAGS is used by a package, these flags are passed to the compiler ahead of flags passed by the package's internal make system. If a package has a header file with the same name as a header file in HOST_DIR, this causes the toolchain to prefer the file from the system include directory because its -I appears first on the command line. Conflicts should prefer the file provided by the package. This can be accomplished by using -isystem, which is more appropriate then -I for system-level include paths. Real-world example: libfdt might be installed in HOST_DIR to install a patched version of QEMU that does not bundle libfdt. Meanwhile, the u-boot package provides its own copy of libfdt.h that is modified from upstream. If libfdt is also installed into HOST_DIR, then host-uboot-tools fails to build because it grabs the libfdt.h from the HOST_DIR area instead of using the patched version from its own source tree. This patch corrects this issue. This assumes the -isystem flag is supported by the host compiler, which is the case since gcc 3.0 at least. Signed-off-by: David Raeman <draeman@bbn.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--package/Makefile.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index afd5d3a59..b0ef70676 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -222,7 +222,7 @@ UNZIP := $(shell which unzip || type -p unzip) -q
APPLY_PATCHES = support/scripts/apply-patches.sh $(if $(QUIET),-s)
-HOST_CPPFLAGS = -I$(HOST_DIR)/usr/include
+HOST_CPPFLAGS = -isystem $(HOST_DIR)/usr/include
HOST_CFLAGS ?= -O2
HOST_CFLAGS += $(HOST_CPPFLAGS)
HOST_CXXFLAGS += $(HOST_CFLAGS)