summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>2014-05-22 13:30:46 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-05-26 22:12:52 +0200
commit89e8b2437c42f50d6a4c55ce24984f58a14d5027 (patch)
tree84d3190f3790b4959a793c41c03fdc241c32dcd6
parent8ca6a6fff28ebee0c8ed3a8234f2923c4af938e5 (diff)
libnss: Enable for MIPS64 n32 platforms
After talking with upstream we concluded that MIPS64 n32 is treated as a 32-bit architecture by libnss because it has 32-bit pointers, so USE_64=1 should not be set in that case. Upstream bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1010730 WRT: http://git.buildroot.net/buildroot/commit/?id=73e6ae0fe6a69f88183ae33401f2314088b5f799 Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
-rw-r--r--package/libnss/Config.in2
-rw-r--r--package/libnss/libnss.mk4
2 files changed, 4 insertions, 2 deletions
diff --git a/package/libnss/Config.in b/package/libnss/Config.in
index 9a1668c6c..690f928e6 100644
--- a/package/libnss/Config.in
+++ b/package/libnss/Config.in
@@ -6,7 +6,6 @@ config BR2_PACKAGE_LIBNSS
depends on BR2_LARGEFILE
depends on BR2_TOOLCHAIN_HAS_THREADS # libnspr
depends on BR2_PACKAGE_LIBNSPR_ARCH_SUPPORT # libnspr
- depends on !BR2_MIPS_NABI32
help
Network Security Services (NSS) is a set of libraries designed
to support development of security-enabled client and server
@@ -19,4 +18,3 @@ config BR2_PACKAGE_LIBNSS
comment "libnss needs a toolchain w/ largefile, threads"
depends on BR2_PACKAGE_LIBNSPR_ARCH_SUPPORT
depends on !BR2_LARGEFILE || !BR2_TOOLCHAIN_HAS_THREADS
- depends on !BR2_MIPS_NABI32
diff --git a/package/libnss/libnss.mk b/package/libnss/libnss.mk
index 666df744c..dcbf8bbb7 100644
--- a/package/libnss/libnss.mk
+++ b/package/libnss/libnss.mk
@@ -30,8 +30,12 @@ LIBNSS_BUILD_VARS = MOZILLA_CLIENT=1 \
OS_TEST="$(ARCH)"
ifeq ($(BR2_ARCH_IS_64),y)
+# MIPS64 n32 is treated as a 32-bit architecture by libnss.
+# See: https://bugzilla.mozilla.org/show_bug.cgi?id=1010730
+ifeq ($(BR2_MIPS_NABI32),)
LIBNSS_BUILD_VARS += USE_64=1
endif
+endif
define LIBNSS_BUILD_CMDS