summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2016-07-03 00:18:11 +0200
committerPeter Korsgaard <peter@korsgaard.com>2016-07-03 12:30:19 +0200
commitae9e43d2facb2ea5441c51891b9277991fc75ebc (patch)
treede8c6a32dd8967d9e0e284a54b9a25316d1f73b9
parent4963a77323532ea70c42da572fec60e32f606f25 (diff)
libminiupnpc: New package
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
-rw-r--r--package/Config.in1
-rw-r--r--package/libminiupnpc/Config.in20
-rw-r--r--package/libminiupnpc/libminiupnpc.hash2
-rw-r--r--package/libminiupnpc/libminiupnpc.mk14
4 files changed, 37 insertions, 0 deletions
diff --git a/package/Config.in b/package/Config.in
index 3fddf8e6d..73bf32f0f 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -1173,6 +1173,7 @@ menu "Networking"
source "package/libmbus/Config.in"
source "package/libmemcached/Config.in"
source "package/libmicrohttpd/Config.in"
+ source "package/libminiupnpc/Config.in"
source "package/libmnl/Config.in"
source "package/libmodbus/Config.in"
source "package/libndp/Config.in"
diff --git a/package/libminiupnpc/Config.in b/package/libminiupnpc/Config.in
new file mode 100644
index 000000000..c24170739
--- /dev/null
+++ b/package/libminiupnpc/Config.in
@@ -0,0 +1,20 @@
+config BR2_PACKAGE_LIBMINIUPNPC
+ bool "libminiupnpc"
+ depends on !BR2_BINFMT_FLAT
+ depends on !BR2_STATIC_LIBS
+ help
+ The UPnP protocol is supported by most home adsl/cable routers
+ and Microsoft Windows 2K/XP. The aim of the MiniUPnP project is
+ to bring a free software solution to support the "Internet
+ Gateway Device" part of the protocol.
+
+ Miniupnpc aims at the simplest library possible, with the
+ smallest footprint and no dependencies to other libraries such
+ as XML parsers or HTTP implementations. All the code is pure
+ ANSI C.
+
+ http://miniupnp.free.fr
+
+comment "libminiupnpc needs a toolchain w/ dynamic library"
+ depends on BR2_STATIC_LIBS
+ depends on !BR2_BINFMT_FLAT
diff --git a/package/libminiupnpc/libminiupnpc.hash b/package/libminiupnpc/libminiupnpc.hash
new file mode 100644
index 000000000..985d69d45
--- /dev/null
+++ b/package/libminiupnpc/libminiupnpc.hash
@@ -0,0 +1,2 @@
+# Locally computed
+sha256 d434ceb8986efbe199c5ca53f90ed53eab290b1e6d0530b717eb6fa49d61f93b miniupnpc-2.0.tar.gz
diff --git a/package/libminiupnpc/libminiupnpc.mk b/package/libminiupnpc/libminiupnpc.mk
new file mode 100644
index 000000000..0eb7cf639
--- /dev/null
+++ b/package/libminiupnpc/libminiupnpc.mk
@@ -0,0 +1,14 @@
+################################################################################
+#
+# libminiupnpc
+#
+################################################################################
+
+LIBMINIUPNPC_VERSION = 2.0
+LIBMINIUPNPC_SOURCE = miniupnpc-$(LIBMINIUPNPC_VERSION).tar.gz
+LIBMINIUPNPC_SITE = http://miniupnp.free.fr/files
+LIBMINIUPNPC_INSTALL_STAGING = YES
+LIBMINIUPNPC_LICENSE = BSD-3c
+LIBMINIUPNPC_LICENSE_FILES = LICENSE
+
+$(eval $(cmake-package))