summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas De Schampheleire <thomas.de.schampheleire@gmail.com>2015-10-19 12:42:09 +0200
committerPeter Korsgaard <peter@korsgaard.com>2015-10-25 21:36:23 +0100
commitdb6fb49e7fcd703f85edddd25dee3d0709a499dd (patch)
tree7bee8d82b49231fdaf5219d1a6ddfa6d9855487d
parent8a8378696634b9a93ecf21f567961b6402b2c9ea (diff)
jq: enable host package
Allow building jq as host utility for use in post-build scripts. This can be useful to created, edit, merge or even perform syntax checking on JSON files. Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
-rw-r--r--package/Config.in.host1
-rw-r--r--package/jq/Config.in.host11
-rw-r--r--package/jq/jq.mk3
3 files changed, 15 insertions, 0 deletions
diff --git a/package/Config.in.host b/package/Config.in.host
index 1f69687b3..ce1b6bcad 100644
--- a/package/Config.in.host
+++ b/package/Config.in.host
@@ -13,6 +13,7 @@ menu "Host utilities"
source "package/genimage/Config.in.host"
source "package/genpart/Config.in.host"
source "package/imx-usb-loader/Config.in.host"
+ source "package/jq/Config.in.host"
source "package/lpc3250loader/Config.in.host"
source "package/mke2img/Config.in.host"
source "package/mtd/Config.in.host"
diff --git a/package/jq/Config.in.host b/package/jq/Config.in.host
new file mode 100644
index 000000000..a0aabc0b3
--- /dev/null
+++ b/package/jq/Config.in.host
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_HOST_JQ
+ bool "host jq"
+ help
+ jq is like sed for JSON data - you can use it to slice and filter
+ and map and transform structured data with the same ease that sed,
+ awk, grep and friends let you play with text.
+
+ As a host tool, jq can be useful to create/edit/merge/check JSON
+ files from a post-build script.
+
+ http://stedolan.github.io/jq/
diff --git a/package/jq/jq.mk b/package/jq/jq.mk
index 8053e392f..9a094ba9a 100644
--- a/package/jq/jq.mk
+++ b/package/jq/jq.mk
@@ -11,8 +11,11 @@ JQ_LICENSE_FILES = COPYING
# uses c99 specific features
JQ_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -std=c99"
+HOST_JQ_CONF_ENV += CFLAGS="$(HOST_CFLAGS) -std=c99"
# jq explicitly enables maintainer mode, which we don't need/want
JQ_CONF_OPTS += --disable-maintainer-mode
+HOST_JQ_CONF_OPTS += --disable-maintainer-mode
$(eval $(autotools-package))
+$(eval $(host-autotools-package))