summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2014-12-23 18:46:33 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-12-27 19:58:29 +0100
commitdb78eb071546c74b7d2e06c9a567e5a3887880c3 (patch)
treeaa001775b9910eb1dd90a0e744f98bd0ae46ca31
parentf84f60c652b1aa29b7bb02dcf1fd76b4498fe1e8 (diff)
package/xbmc-addon-xvdr: rename to kodi-addon-xvdr
Following the rename of the XBMC project to Kodi, this commit renames the xbmc-addon-xvdr package to kodi-addon-xvdr, and adds the appropriate Config.in.legacy handling. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--Config.in.legacy7
-rw-r--r--package/kodi-addon-xvdr/Config.in (renamed from package/xbmc-addon-xvdr/Config.in)8
-rw-r--r--package/kodi-addon-xvdr/kodi-addon-xvdr.mk (renamed from package/xbmc-addon-xvdr/xbmc-addon-xvdr.mk)20
-rw-r--r--package/kodi/Config.in2
4 files changed, 22 insertions, 15 deletions
diff --git a/Config.in.legacy b/Config.in.legacy
index 653eeac72..de2c0bad6 100644
--- a/Config.in.legacy
+++ b/Config.in.legacy
@@ -102,6 +102,13 @@ endif
comment "Legacy options removed in 2015.02"
+config BR2_PACKAGE_XBMC_ADDON_XVDR
+ bool "xbmc options have been renamed"
+ select BR2_LEGACY
+ select BR2_PACKAGE_KODI_ADDON_XVDR
+ help
+ The XBMC media center project was renamed to Kodi entertainment center
+
config BR2_PACKAGE_XBMC_PVR_ADDONS
bool "xbmc options have been renamed"
select BR2_LEGACY
diff --git a/package/xbmc-addon-xvdr/Config.in b/package/kodi-addon-xvdr/Config.in
index 7329a9afc..6e713af6f 100644
--- a/package/xbmc-addon-xvdr/Config.in
+++ b/package/kodi-addon-xvdr/Config.in
@@ -1,8 +1,8 @@
-config BR2_PACKAGE_XBMC_ADDON_XVDR
- bool "xbmc-addon-xvdr"
+config BR2_PACKAGE_KODI_ADDON_XVDR
+ bool "kodi-addon-xvdr"
help
- This is a PVR add-on for XBMC to add VDR (http://tvdr.de/)
- as a TV/PVR Backend to XBMC.
+ This is a PVR add-on for Kodi to add VDR (http://tvdr.de/)
+ as a TV/PVR Backend to Kodi.
It adds support for Live TV watching, replaying of Recordings,
programming Timers and EPG TV Guide to use on same computer or
diff --git a/package/xbmc-addon-xvdr/xbmc-addon-xvdr.mk b/package/kodi-addon-xvdr/kodi-addon-xvdr.mk
index 16f3a0d57..14b08fe92 100644
--- a/package/xbmc-addon-xvdr/xbmc-addon-xvdr.mk
+++ b/package/kodi-addon-xvdr/kodi-addon-xvdr.mk
@@ -1,26 +1,26 @@
################################################################################
#
-# xbmc-addon-xvdr
+# kodi-addon-xvdr
#
################################################################################
# This cset is on master. When a Gotham branch is made, we should
# follow it, as incompatible changes in the plugins API can happen
# on the master branch.
-XBMC_ADDON_XVDR_VERSION = 82b5093ad33847f97a978cb620c9a87d2dbcf7eb
-XBMC_ADDON_XVDR_SITE = $(call github,pipelka,xbmc-addon-xvdr,$(XBMC_ADDON_XVDR_VERSION))
-XBMC_ADDON_XVDR_LICENSE = GPLv2+
-XBMC_ADDON_XVDR_LICENSE_FILES = COPYING
+KODI_ADDON_XVDR_VERSION = 82b5093ad33847f97a978cb620c9a87d2dbcf7eb
+KODI_ADDON_XVDR_SITE = $(call github,pipelka,xbmc-addon-xvdr,$(KODI_ADDON_XVDR_VERSION))
+KODI_ADDON_XVDR_LICENSE = GPLv2+
+KODI_ADDON_XVDR_LICENSE_FILES = COPYING
# There's no ./configure in the git tree, we need to generate it
-# xbmc-addon-xvdr uses a weird autogen.sh script, which
+# kodi-addon-xvdr uses a weird autogen.sh script, which
# is even incorrect (it's missing the #! ) Sigh... :-(
# Fortunately, with our little patch, it autoreconfs nicely! :-)
-XBMC_ADDON_XVDR_AUTORECONF = YES
+KODI_ADDON_XVDR_AUTORECONF = YES
-# This really is a runtime dependency, but we need XBMC to be installed
-# first, since we'll install files in XBMC's directories _after_ XBMC has
+# This really is a runtime dependency, but we need KODI to be installed
+# first, since we'll install files in KODI's directories _after_ KODI has
# installed his own files
-XBMC_ADDON_XVDR_DEPENDENCIES = kodi
+KODI_ADDON_XVDR_DEPENDENCIES = kodi
$(eval $(autotools-package))
diff --git a/package/kodi/Config.in b/package/kodi/Config.in
index d1286b7ea..4bc017873 100644
--- a/package/kodi/Config.in
+++ b/package/kodi/Config.in
@@ -237,7 +237,7 @@ config BR2_PACKAGE_KODI_WAVPACK
comment "Kodi addons"
-source "package/xbmc-addon-xvdr/Config.in"
+source "package/kodi-addon-xvdr/Config.in"
source "package/kodi-pvr-addons/Config.in"
endif # BR2_PACKAGE_KODI