summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2016-07-24 21:15:59 -0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-07-25 22:47:47 +0200
commitfb640120d8a3e6816cf57b479f93064e84df8640 (patch)
tree98631d739f7589868558dcea48f4224cb35fd878
parentb9cece6994fd1fd896e671a7063846dd154703b3 (diff)
nettle: disable assembly optimizations for ARMv7M
It's thumb2-only and it requires ARM instructions. Since V4 and V5 aren't enough either use the V7M knob to avoid over-complicating the conditional. Fixes: http://autobuild.buildroot.net/results/354/35418d33efa902d3a1a82b2cd58d8db1b1172e49/ Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--package/nettle/nettle.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/nettle/nettle.mk b/package/nettle/nettle.mk
index c133839e5..a94a7fc3d 100644
--- a/package/nettle/nettle.mk
+++ b/package/nettle/nettle.mk
@@ -15,7 +15,7 @@ NETTLE_LICENSE_FILES = COPYING.LESSERv3 COPYINGv2
NETTLE_CONF_OPTS = --disable-openssl
# ARM assembly requires v6+ ISA
-ifeq ($(BR2_ARM_CPU_ARMV4)$(BR2_ARM_CPU_ARMV5),y)
+ifeq ($(BR2_ARM_CPU_ARMV4)$(BR2_ARM_CPU_ARMV5)$(BR2_ARM_CPU_ARMV7M),y)
NETTLE_CONF_OPTS += --disable-assembler
endif