summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorMaxime Hadjinlian <maxime.hadjinlian@gmail.com>2015-07-12 17:25:57 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-07-12 21:55:14 +0200
commit76d1c729f09db5ecc514ae0520f9a53c353e0401 (patch)
treec5669cd1690045caa8e04c298f4b338de0afc43a /Makefile
parent470cd0dcada5c2df8c84d89dba1077ad74d1e599 (diff)
package: Remove shell completion at finalize stage
Instead of doing a removal of the completion file package per package, do it all at the finalize stage so it's done once and for all. Note: This fixes an issue with systemd where passing a --bashcompletiondir or --zshcompletiondir would be evaluated to '.' by the autotools macro. This would create a 'target./' directory. Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 35818f08f..daf692e59 100644
--- a/Makefile
+++ b/Makefile
@@ -556,6 +556,12 @@ target-finalize: $(PACKAGES)
ifneq ($(BR2_PACKAGE_GDB),y)
rm -rf $(TARGET_DIR)/usr/share/gdb
endif
+ifneq ($(BR2_PACKAGE_BASH),y)
+ rm -rf $(TARGET_DIR)/usr/share/bash-completion
+endif
+ifneq ($(BR2_PACKAGE_ZSH),y)
+ rm -rf $(TARGET_DIR)/usr/share/zsh
+endif
rm -rf $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/man
rm -rf $(TARGET_DIR)/usr/info $(TARGET_DIR)/usr/share/info
rm -rf $(TARGET_DIR)/usr/doc $(TARGET_DIR)/usr/share/doc