summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorRomain Naour <romain.naour@gmail.com>2016-01-20 22:53:19 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-01-20 23:00:01 +0100
commit86229d64eb1c17bd7fa71aff6c198f4326b81c25 (patch)
tree260d9867f7b747a29b80381568347416a7634fa8 /Makefile
parentf850ff4ccaabefbffb905c69a1697312a301326a (diff)
core: override the user's locale while setting HOSTARCH
At least with French user's locale HOSTARCH is empty since 'Target' is not present in gcc output. gcc -v 2>&1 Utilisation des specs internes. COLLECT_GCC=gcc COLLECT_LTO_WRAPPER=/usr/libexec/gcc/x86_64-redhat-linux/5.3.1/lto-wrapper Cible : x86_64-redhat-linux Override the user's local with LC_ALL=C. Signed-off-by: Romain Naour <romain.naour@gmail.com> Cc: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 2e09611af..17c181bba 100644
--- a/Makefile
+++ b/Makefile
@@ -297,7 +297,7 @@ export HOSTCC_NOCCACHE HOSTCXX_NOCCACHE
# So, we extract the first part of the tuple the host gcc was
# configured to generate code for; we assume this is our userland.
#
-export HOSTARCH := $(shell $(HOSTCC_NOCCACHE) -v 2>&1 | \
+export HOSTARCH := $(shell LC_ALL=C $(HOSTCC_NOCCACHE) -v 2>&1 | \
sed -e '/^Target: \([^-]*\).*/!d' \
-e 's//\1/' \
-e 's/i.86/x86/' \