summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2016-02-07 22:34:29 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-07 23:21:55 +0100
commit9dac986696a34d30a1e1408df961710edc748bdf (patch)
treed05eb9aa038211fd8a84f31e3271d6dcc59de09d /Makefile
parent90551bfac01a41979ab24ff58bfb80742f8470ae (diff)
core: add a make target to check the dependencies
Add a make target that will checks the dependencies of all packages. This will currently only detect circular dependencies, but more tests can be added later if need be. This can then be used in the autobuilders to automatically report dependency issues. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 7c5daa43b..9daf0110c 100644
--- a/Makefile
+++ b/Makefile
@@ -733,6 +733,10 @@ graph-size:
--file-size-csv $(GRAPHS_DIR)/file-size-stats.csv \
--package-size-csv $(GRAPHS_DIR)/package-size-stats.csv
+check-dependencies:
+ @cd "$(CONFIG_DIR)"; \
+ $(TOPDIR)/support/scripts/graph-depends -C
+
else # ifeq ($(BR2_HAVE_DOT_CONFIG),y)
all: menuconfig