diff options
author | Masahiro Yamada <yamada.masahiro@socionext.com> | 2015-04-09 20:28:55 +0900 |
---|---|---|
committer | Thomas Petazzoni <thomas.petazzoni@free-electrons.com> | 2015-04-09 21:44:41 +0200 |
commit | a9847d1483c74ab424ef5421faed5057781125cd (patch) | |
tree | 6be0d89e22cac1f44d4e28f5a78beb8d4ea2981a /Makefile | |
parent | 52a12b7b1e0e98b02d0c6e55424c2f71d73b3ab0 (diff) |
Makefile: delete HOSTFC and FC_FOR_BUILD
This definition of HOSTFC is completely wrong.
"$(HOSTLD)" should be "$(HOSTFC)". Also, "echo" always succeeds, so
"which g77 || type -p g77 || echo gfortran" is never run.
Anyway, HOSTFC is most likely set to "/use/bin/ld" and nobody has
complained about it before me, so I guess it is not used at all.
At least grepping HOSTFC, FC_FOR_BUILD did not hit any packages.
Drop HOSTFC and FC_FOR_BUILD.
Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 6 |
1 files changed, 1 insertions, 5 deletions
@@ -228,9 +228,6 @@ HOSTCXX := g++ HOSTCXX := $(shell which $(HOSTCXX) || type -p $(HOSTCXX) || echo g++) endif HOSTCXX_NOCCACHE := $(HOSTCXX) -ifndef HOSTFC -HOSTFC := gfortran -endif ifndef HOSTCPP HOSTCPP := cpp endif @@ -251,7 +248,6 @@ HOSTRANLIB := ranlib endif HOSTAR := $(shell which $(HOSTAR) || type -p $(HOSTAR) || echo ar) HOSTAS := $(shell which $(HOSTAS) || type -p $(HOSTAS) || echo as) -HOSTFC := $(shell which $(HOSTLD) || type -p $(HOSTLD) || echo || which g77 || type -p g77 || echo gfortran) HOSTCPP := $(shell which $(HOSTCPP) || type -p $(HOSTCPP) || echo cpp) HOSTLD := $(shell which $(HOSTLD) || type -p $(HOSTLD) || echo ld) HOSTLN := $(shell which $(HOSTLN) || type -p $(HOSTLN) || echo ln) @@ -259,7 +255,7 @@ HOSTNM := $(shell which $(HOSTNM) || type -p $(HOSTNM) || echo nm) HOSTOBJCOPY := $(shell which $(HOSTOBJCOPY) || type -p $(HOSTOBJCOPY) || echo objcopy) HOSTRANLIB := $(shell which $(HOSTRANLIB) || type -p $(HOSTRANLIB) || echo ranlib) -export HOSTAR HOSTAS HOSTCC HOSTCXX HOSTFC HOSTLD +export HOSTAR HOSTAS HOSTCC HOSTCXX HOSTLD export HOSTCC_NOCCACHE HOSTCXX_NOCCACHE # Make sure pkg-config doesn't look outside the buildroot tree |