summaryrefslogtreecommitdiff
path: root/boot/barebox
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-03-29 19:33:22 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-04-06 11:04:59 +0200
commit0eba4759fab9d093afacac77a0ac31f1f0b3cceb (patch)
treeccebbcb4f86905d319d33da1e4a724a7d41b17f0 /boot/barebox
parentea8edb95144456529ad3047bce86b7449438ca42 (diff)
packages: apply custom patches using *.patch instead of <pkg>-*.patch
Several packages have some logic to apply custom patches that existed before the BR2_GLOBAL_PATCH_DIR mechanism: at91bootstrap, at91bootstrap3, barebox, uboot and linux. Currently, the logic of those packages to apply custom patches is to match <package-name>-*.patch, which is not consistent with what we've done for patches stored in the package directory, and for patches stored in BR2_GLOBAL_PATCH_DIR: in such cases, we simply apply *.patch. Therefore, for consistency reasons, this commit changes these packages to also apply *.patch. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Diffstat (limited to 'boot/barebox')
-rw-r--r--boot/barebox/barebox.mk5
1 files changed, 2 insertions, 3 deletions
diff --git a/boot/barebox/barebox.mk b/boot/barebox/barebox.mk
index 5809fb029..98cb04ea0 100644
--- a/boot/barebox/barebox.mk
+++ b/boot/barebox/barebox.mk
@@ -26,9 +26,8 @@ BAREBOX_LICENSE_FILES = COPYING
ifneq ($(call qstrip,$(BR2_TARGET_BAREBOX_CUSTOM_PATCH_DIR)),)
define BAREBOX_APPLY_CUSTOM_PATCHES
- $(APPLY_PATCHES) $(@D) \
- $(BR2_TARGET_BAREBOX_CUSTOM_PATCH_DIR) \
- barebox-$(BAREBOX_VERSION)-\*.patch
+ $(APPLY_PATCHES) $(@D)
+ $(BR2_TARGET_BAREBOX_CUSTOM_PATCH_DIR) \*.patch
endef
BAREBOX_POST_PATCH_HOOKS += BAREBOX_APPLY_CUSTOM_PATCHES