summaryrefslogtreecommitdiff
path: root/boot/grub2/grub2.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-06-09 00:21:47 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-06-14 23:24:59 +0200
commit8decd25477fe5a8bb314e65c9b1a2c9d54bc9124 (patch)
treebd59d7126aac60558cfd5ff0eed68a8d0b549168 /boot/grub2/grub2.mk
parent5bac06e8810eb86e7bddc771fda68f0c59a3c3fa (diff)
grub2: prepare and install El Torito image
In order to support ISO9660 bootable images that rely on Grub 2, this commit modifies thr Grub 2 makefile to generate and install an El Torito image. Such an image is simply produced by concatenating the cdboot.img provided by Grub 2, and the Grub 2 image generated by Buildroot using grub-mkimage. Since this action is so simple and cost-free, we don't bother adding a Grub 2 sub-option for that, and simply generate the El Torito image unconditionally. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Diffstat (limited to 'boot/grub2/grub2.mk')
-rw-r--r--boot/grub2/grub2.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/boot/grub2/grub2.mk b/boot/grub2/grub2.mk
index 697f0adc1..280b4d62a 100644
--- a/boot/grub2/grub2.mk
+++ b/boot/grub2/grub2.mk
@@ -76,6 +76,8 @@ define GRUB2_IMAGE_INSTALLATION
-p "$(GRUB2_PREFIX)" \
$(if $(GRUB2_BUILTIN_CONFIG),-c $(GRUB2_BUILTIN_CONFIG)) \
$(GRUB2_BUILTIN_MODULES)
+ cat $(HOST_DIR)/usr/lib/grub/$(GRUB2_TUPLE)/cdboot.img $(GRUB2_IMAGE) > \
+ $(BINARIES_DIR)/grub-eltorito.img
mkdir -p $(dir $(GRUB2_CFG))
$(INSTALL) -D -m 0644 boot/grub2/grub.cfg $(GRUB2_CFG)
endef