summaryrefslogtreecommitdiff
path: root/boot
diff options
context:
space:
mode:
authorJan Viktorin <viktorin@rehivetech.com>2015-07-14 17:14:01 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-07-15 00:06:04 +0200
commit920b50b7e0d7535899ccba77b85d3df57e2c2a2a (patch)
tree256701860f60ccb9fa5dc6eeae7170aa1b90fbd0 /boot
parent0b8e10c2ed913b53646c26424893f43dc42cfa15 (diff)
boot/uboot: Add support for dtb.img format
Allow to generate u-boot-dtb.img. This is the same format as u-boot.img, however, it contains a built-in device-tree. This file is being loaded by the U-Boot SPL. Signed-off-by: Jan Viktorin <viktorin@rehivetech.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'boot')
-rw-r--r--boot/uboot/Config.in3
-rw-r--r--boot/uboot/uboot.mk2
2 files changed, 5 insertions, 0 deletions
diff --git a/boot/uboot/Config.in b/boot/uboot/Config.in
index fa1741c1d..1cdb2fae9 100644
--- a/boot/uboot/Config.in
+++ b/boot/uboot/Config.in
@@ -106,6 +106,9 @@ config BR2_TARGET_UBOOT_FORMAT_AIS
config BR2_TARGET_UBOOT_FORMAT_BIN
bool "u-boot.bin"
+config BR2_TARGET_UBOOT_FORMAT_DTB_IMG
+ bool "u-boot-dtb.img"
+
config BR2_TARGET_UBOOT_FORMAT_IMG
bool "u-boot.img"
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index 2cfff282c..805367807 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -45,6 +45,8 @@ else ifeq ($(BR2_TARGET_UBOOT_FORMAT_LDR),y)
UBOOT_BIN = u-boot.ldr
else ifeq ($(BR2_TARGET_UBOOT_FORMAT_NAND_BIN),y)
UBOOT_BIN = u-boot-nand.bin
+else ifeq ($(BR2_TARGET_UBOOT_FORMAT_DTB_IMG),y)
+UBOOT_BIN = u-boot-dtb.img
else ifeq ($(BR2_TARGET_UBOOT_FORMAT_IMG),y)
UBOOT_BIN = u-boot.img
else ifeq ($(BR2_TARGET_UBOOT_FORMAT_IMX),y)