summaryrefslogtreecommitdiff
path: root/fs/common.mk
diff options
context:
space:
mode:
authorThomas De Schampheleire <thomas.de.schampheleire@gmail.com>2015-03-09 10:34:13 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-03-09 14:10:13 +0100
commit26e0d500b58cb6ccfdb84426ba2f866ada3b01f3 (patch)
treec2fa4b14b0bbfcef69712ad9ce52f11da1cbd508 /fs/common.mk
parentd92f9c6832fd733919ad7ade91d8fc0bd0f18e1b (diff)
fs/common: build host-xz when xz compression is used
When a filesystem image is xz-compressed, the XZ variable is used to refer to the xz compression tool, but it is not necessarily available. Add a proper dependency to fix that. Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'fs/common.mk')
-rw-r--r--fs/common.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/fs/common.mk b/fs/common.mk
index 1d3926f98..5d07f0056 100644
--- a/fs/common.mk
+++ b/fs/common.mk
@@ -62,6 +62,7 @@ ROOTFS_$(2)_COMPRESS_EXT = .lzo
ROOTFS_$(2)_COMPRESS_CMD = $$(LZOP) -9 -c
endif
ifeq ($$(BR2_TARGET_ROOTFS_$(2)_XZ),y)
+ROOTFS_$(2)_DEPENDENCIES += host-xz
ROOTFS_$(2)_COMPRESS_EXT = .xz
ROOTFS_$(2)_COMPRESS_CMD = xz -9 -C crc32 -c
endif