summaryrefslogtreecommitdiff
path: root/fs/common.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-04-12 18:37:46 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-04-14 10:12:32 +0200
commit2aef771f6e05d3fd1ea59c2faab986eaa55f28f7 (patch)
tree67047258ad2172dd4461df6f0f7d2141564c98fa /fs/common.mk
parentf1e843864f89b58f806af371e0a09b1c219c522e (diff)
fs: declare phony targets as such
This commit improves the filesystem handling code to declare its various targets as PHONY when appropriate. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Diffstat (limited to 'fs/common.mk')
-rw-r--r--fs/common.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/fs/common.mk b/fs/common.mk
index 5d07f0056..cac127fee 100644
--- a/fs/common.mk
+++ b/fs/common.mk
@@ -102,6 +102,8 @@ rootfs-$(1)-show-depends:
rootfs-$(1): $$(BINARIES_DIR)/rootfs.$(1) $$(ROOTFS_$(2)_POST_TARGETS)
+.PHONY: rootfs-$(1) rootfs-$(1)-show-depends
+
ifeq ($$(BR2_TARGET_ROOTFS_$(2)),y)
TARGETS_ROOTFS += rootfs-$(1)
endif