summaryrefslogtreecommitdiff
path: root/fs/iso9660/iso9660.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-06-09 00:21:46 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-06-14 23:24:52 +0200
commit5bac06e8810eb86e7bddc771fda68f0c59a3c3fa (patch)
tree6243352f59da409cb335605389a5845b7a67f85a /fs/iso9660/iso9660.mk
parentf9ac784ee68057715ce2f61ad8156228b4e0ddf4 (diff)
fs/iso9660: add hybrid image support
This commit adds a new option, which allows, when isolinux is used as the bootloader, to generate an "hybrid" ISO image. Such images can either be booted from CD-ROM or from USB keys. It simply uses the isohybrid tool provided by syslinux. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Diffstat (limited to 'fs/iso9660/iso9660.mk')
-rw-r--r--fs/iso9660/iso9660.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/fs/iso9660/iso9660.mk b/fs/iso9660/iso9660.mk
index 588e07bf8..4f4abea9f 100644
--- a/fs/iso9660/iso9660.mk
+++ b/fs/iso9660/iso9660.mk
@@ -140,4 +140,12 @@ define ROOTFS_ISO9660_CMD
-o $@ $(ROOTFS_ISO9660_TARGET_DIR)
endef
+ifeq ($(BR2_TARGET_ROOTFS_ISO9660_HYBRID),y)
+define ROOTFS_ISO9660_GEN_HYBRID
+ $(HOST_DIR)/usr/bin/isohybrid -t 0x96 $@
+endef
+
+ROOTFS_ISO9660_POST_GEN_HOOKS += ROOTFS_ISO9660_GEN_HYBRID
+endif
+
$(eval $(call ROOTFS_TARGET,iso9660))