summaryrefslogtreecommitdiff
path: root/fs/squashfs
diff options
context:
space:
mode:
authorThomas De Schampheleire <patrickdepinguin@gmail.com>2014-01-03 17:02:53 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-01-10 15:14:35 +0100
commit2f7a53ee8a58846ea3b43e140819fdfeff5e7142 (patch)
treeceb156c00bc67583b13f59e54f6bc38bd2d94f9f /fs/squashfs
parentba4ad9d27c4ddf9f2d1368a978f622bd66850e72 (diff)
squashfs3: remove deprecated package/rootfs
[Peter: remove now unused BR2_DEPRECATED_SINCE_2010_05 symbol] Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'fs/squashfs')
-rw-r--r--fs/squashfs/Config.in16
-rw-r--r--fs/squashfs/squashfs.mk12
2 files changed, 0 insertions, 28 deletions
diff --git a/fs/squashfs/Config.in b/fs/squashfs/Config.in
index ff3b8843e..817909d62 100644
--- a/fs/squashfs/Config.in
+++ b/fs/squashfs/Config.in
@@ -4,26 +4,10 @@ config BR2_TARGET_ROOTFS_SQUASHFS
Build a squashfs root filesystem
if BR2_TARGET_ROOTFS_SQUASHFS
-choice
- prompt "SquashFS version"
- default BR2_TARGET_ROOTFS_SQUASHFS4
- help
- Select the Squash filesystem version to use to generate the
- root filesystem.
-
-config BR2_TARGET_ROOTFS_SQUASHFS4
- bool "4.x"
-
-config BR2_TARGET_ROOTFS_SQUASHFS3
- depends on BR2_DEPRECATED_SINCE_2010_05
- bool "3.x"
-
-endchoice
choice
prompt "Compression algorithm"
default BR2_TARGET_ROOTFS_SQUASHFS4_GZIP
- depends on BR2_TARGET_ROOTFS_SQUASHFS4
help
Select the squashfs compression algorithm to use when
generating the filesystem.
diff --git a/fs/squashfs/squashfs.mk b/fs/squashfs/squashfs.mk
index ae5182a1a..eb5fc3e73 100644
--- a/fs/squashfs/squashfs.mk
+++ b/fs/squashfs/squashfs.mk
@@ -4,7 +4,6 @@
#
################################################################################
-ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS4),y)
ROOTFS_SQUASHFS_DEPENDENCIES = host-squashfs
ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS4_LZO),y)
@@ -21,17 +20,6 @@ endif
endif
endif
-else
-ROOTFS_SQUASHFS_DEPENDENCIES = host-squashfs3
-
-ifeq ($(BR2_ENDIAN),"BIG")
-ROOTFS_SQUASHFS_ARGS=-be
-else
-ROOTFS_SQUASHFS_ARGS=-le
-endif
-
-endif
-
define ROOTFS_SQUASHFS_CMD
$(HOST_DIR)/usr/bin/mksquashfs $(TARGET_DIR) $@ -noappend \
$(ROOTFS_SQUASHFS_ARGS) && \