summaryrefslogtreecommitdiff
path: root/fs
diff options
context:
space:
mode:
authorEric Le Bihan <eric.le.bihan.dev@free.fr>2014-04-20 19:33:09 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-04-21 14:07:31 +0200
commitb019490adf56a7ccdf81f3bdf11dfd017c33b738 (patch)
treebb94bf1b3b4db2acd4b566045bf633d3448c1e74 /fs
parent773ee9797ad4c74e967ad959f6ce0677b6c66677 (diff)
system: add ability to pass additional users tables.
A new entry has been added to the "System Configuration" menu to allow the user to set the location of additional user tables (besides the ones defined in packages). A user table is a text file, formatted using the mkusers syntax, which describes the users on the target system, with their UID/GID, home directory, password, etc. The target root file system will be populated according the content of these files. Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr> [yann.morin.1998@free.fr: use plural TABLES; we need to remove the intermediate users_table file, as it is no longer generated in one shot, in case a previous run failed and did not remove it] Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'fs')
-rw-r--r--fs/common.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/fs/common.mk b/fs/common.mk
index 080b8c687..831365ef1 100644
--- a/fs/common.mk
+++ b/fs/common.mk
@@ -33,6 +33,7 @@ FULL_DEVICE_TABLE = $(BUILD_DIR)/_device_table.txt
ROOTFS_DEVICE_TABLES = $(call qstrip,$(BR2_ROOTFS_DEVICE_TABLE) \
$(BR2_ROOTFS_STATIC_DEVICE_TABLE))
USERS_TABLE = $(BUILD_DIR)/_users_table.txt
+ROOTFS_USERS_TABLES = $(call qstrip,$(BR2_ROOTFS_USERS_TABLES))
define ROOTFS_TARGET_INTERNAL
@@ -68,6 +69,7 @@ $$(BINARIES_DIR)/rootfs.$(1): target-finalize $$(ROOTFS_$(2)_DEPENDENCIES)
$$(foreach hook,$$(ROOTFS_$(2)_PRE_GEN_HOOKS),$$(call $$(hook))$$(sep))
rm -f $$(FAKEROOT_SCRIPT)
rm -f $$(TARGET_DIR_WARNING_FILE)
+ rm -f $(USERS_TABLE)
echo "chown -R 0:0 $$(TARGET_DIR)" >> $$(FAKEROOT_SCRIPT)
ifneq ($$(ROOTFS_DEVICE_TABLES),)
cat $$(ROOTFS_DEVICE_TABLES) > $$(FULL_DEVICE_TABLE)
@@ -77,7 +79,10 @@ endif
printf '$$(subst $$(sep),\n,$$(PACKAGES_PERMISSIONS_TABLE))' >> $$(FULL_DEVICE_TABLE)
echo "$$(HOST_DIR)/usr/bin/makedevs -d $$(FULL_DEVICE_TABLE) $$(TARGET_DIR)" >> $$(FAKEROOT_SCRIPT)
endif
- printf '$(subst $(sep),\n,$(PACKAGES_USERS))' > $(USERS_TABLE)
+ifneq ($$(ROOTFS_USERS_TABLES),)
+ cat $$(ROOTFS_USERS_TABLES) >> $(USERS_TABLE)
+endif
+ printf '$(subst $(sep),\n,$(PACKAGES_USERS))' >> $(USERS_TABLE)
$(TOPDIR)/support/scripts/mkusers $(USERS_TABLE) $(TARGET_DIR) >> $(FAKEROOT_SCRIPT)
echo "$$(ROOTFS_$(2)_CMD)" >> $$(FAKEROOT_SCRIPT)
chmod a+x $$(FAKEROOT_SCRIPT)