summaryrefslogtreecommitdiff
path: root/linux/linux-ext-fbtft.mk
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2015-03-14 15:25:19 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-04-09 22:52:20 +0200
commit53785a2c77e723c394197df68efb71d6938e1884 (patch)
treed678d26afff6102b12184d05820c1067ad336d9d /linux/linux-ext-fbtft.mk
parent677c4b5f9763e6d3380b9f149de36a674b559eda (diff)
linux: fix extensions
Since the move to the kconfig-package infra, linux extensions are broken. In our linux package, extensions are applied as pre-patch hooks. Before the kconfig-package infra, we had custom rules for the linux-*config targets, which were of the form: linux-menuconfig: linux-configure $(MAKE) -C $(LINUX_DIR) menuconfig This caused the linux tree to be fully configured before running the configurators, and thus linux dependencies were entirely fullfilled, and extensions were properly applied. Since we migrated (in dff25ea), the kconfig-package infra introduces a (hidden, internal) intermediate step 'kconfig-fixup' and decorelates the kconfig-part of the configuration from the actual package-part of the configuration: linux-configure -------> kconfig-fixup --> .config --> $(LINUX_CONFIG_FILE) / linux-menuconfig --' As thus, this (very useful!) use-case breaks (starting from a clean Buildroot tree): make menuconfig -> enable a kernel and at least one extension -> save and exit make linux-menuconfig -> extensions are not available Fix that by using the newly-introduced patch-dependencies, so that extensions are available before we try to patch the linux kernel. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Thomas De Schampheleire <patrickdepinguin@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'linux/linux-ext-fbtft.mk')
-rw-r--r--linux/linux-ext-fbtft.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/linux/linux-ext-fbtft.mk b/linux/linux-ext-fbtft.mk
index 36f4fd22d..6892c89a4 100644
--- a/linux/linux-ext-fbtft.mk
+++ b/linux/linux-ext-fbtft.mk
@@ -6,7 +6,7 @@
ifeq ($(BR2_LINUX_KERNEL_EXT_FBTFT),y)
# Add dependency to fbtft package (download helper for the fbtft source)
-LINUX_DEPENDENCIES += fbtft
+LINUX_PATCH_DEPENDENCIES += fbtft
# for linux >= 3.15 install to drivers/video/fbdev/fbtft
# for linux < 3.15 install to drivers/video/fbtft