summaryrefslogtreecommitdiff
path: root/linux/linux.mk
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2014-01-28 21:11:23 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-01-28 22:56:17 +0100
commit0a541c8f244971a45396bfa4c371444204ed4a2c (patch)
treeb63802687d9b03e7421b00e9251afee5663bd871 /linux/linux.mk
parent9b659b815bbb747590f64f57066b36b938946353 (diff)
linux: ensure buildroot_defconfig is writable
If $(KERNEL_SOURCE_CONFIG) is read-only (eg. because Buildroot's source dir is), the rm of $(KERNEL_ARCH_PATH)/configs/buildroot_defconfig will either fail, or prompt the user, both of which we want to avoid. Make it writable by using $(INSTALL). Fixes: #4363 Signed-off-by: Nathan Lynch <ntl@pobox.com> [yann.morin.1998@free.fr: use $(INSTALL) instead of cp, don't 'rm -f'] Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'linux/linux.mk')
-rw-r--r--linux/linux.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index ab25fe987..62033d280 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -164,7 +164,7 @@ KERNEL_SOURCE_CONFIG = $(BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE)
endif
define LINUX_CONFIGURE_CMDS
- cp $(KERNEL_SOURCE_CONFIG) $(KERNEL_ARCH_PATH)/configs/buildroot_defconfig
+ $(INSTALL) -m 0644 $(KERNEL_SOURCE_CONFIG) $(KERNEL_ARCH_PATH)/configs/buildroot_defconfig
$(TARGET_MAKE_ENV) $(MAKE1) $(LINUX_MAKE_FLAGS) -C $(@D) buildroot_defconfig
rm $(KERNEL_ARCH_PATH)/configs/buildroot_defconfig
$(if $(BR2_arm)$(BR2_armeb),