summaryrefslogtreecommitdiff
path: root/linux/linux.mk
diff options
context:
space:
mode:
authorHollis Blanchard <hollis_blanchard@mentor.com>2015-08-11 17:11:49 -0700
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-01-19 21:46:58 +0100
commit5bbbc5b7446933dcb1a08a20d5e58dc527b3e4a7 (patch)
treef7b4c1b357024373e0a375fd10e91d4187383476 /linux/linux.mk
parentfd999c8a37487c13e05659f255c1c25850846e4b (diff)
linux: handle read-only dts files
Some fine version control systems make all files read-only. The custom DTS file may therefore be read-only, and that permission is preserved when copying into the Linux build directory. A subsequent rebuild tries to 'cp' again, which fails with a "Permission denied" error unless the -f option is used. Signed-off-by: Hollis Blanchard <hollis_blanchard@mentor.com> Acked-by: Nikolay Dimitrov <picmaster@mail.bg> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'linux/linux.mk')
-rw-r--r--linux/linux.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index 045294b2c..3c53a0bc0 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -304,7 +304,7 @@ endif
# configuration has changed.
define LINUX_BUILD_CMDS
$(if $(BR2_LINUX_KERNEL_USE_CUSTOM_DTS),
- cp $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_DTS_PATH)) $(KERNEL_ARCH_PATH)/boot/dts/)
+ cp -f $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_DTS_PATH)) $(KERNEL_ARCH_PATH)/boot/dts/)
$(LINUX_MAKE_ENV) $(MAKE) $(LINUX_MAKE_FLAGS) -C $(@D) $(LINUX_TARGET_NAME)
@if grep -q "CONFIG_MODULES=y" $(@D)/.config; then \
$(LINUX_MAKE_ENV) $(MAKE) $(LINUX_MAKE_FLAGS) -C $(@D) modules ; \