summaryrefslogtreecommitdiff
path: root/linux/linux.mk
diff options
context:
space:
mode:
authorSebastian Frias <sf84@laposte.net>2016-04-25 16:52:17 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-04-25 21:40:47 +0200
commitb1f0212af66e374f2a5f88edd8d3f4b2b8a90d9b (patch)
treeaf10e6bb8e0e99fcdde198795de50522b1d5cd3b /linux/linux.mk
parent7410b8e0ce50c6a989e5708f86518b164fad40b2 (diff)
linux: properly install all images in the initramfs case
The target "$(LINUX_DIR)/.stamp_initramfs_rebuilt" uses its own 'cp' command, instead of LINUX_INSTALL_IMAGE/LINUX_INSTALL_IMAGES_CMDS provided by (or updated with) commit 055e6162bba7 ("linux: don't build appended DTB image in place and support multiple images") and thus is not operating properly when APPENDED_DTB is used. Indeed, it copies a single image, and does not copy the one with the DTB appended. This patch replaces the 'cp' command with LINUX_INSTALL_IMAGE which handles APPENDED_DTB. Fixes: 055e6162bba7 ("linux: don't build appended DTB image in place and support multiple images") Signed-off-by: Sebastian Frias <sf84@laposte.net> Tested-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'linux/linux.mk')
-rw-r--r--linux/linux.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index 317587f1d..d88060e09 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -447,8 +447,8 @@ $(LINUX_DIR)/.stamp_initramfs_rebuilt: $(LINUX_DIR)/.stamp_target_installed $(LI
# Build the kernel.
$(LINUX_MAKE_ENV) $(MAKE) $(LINUX_MAKE_FLAGS) -C $(@D) $(LINUX_TARGET_NAME)
$(LINUX_APPEND_DTB)
- # Copy the kernel image to its final destination
- cp $(LINUX_IMAGE_PATH) $(BINARIES_DIR)
+ # Copy the kernel image(s) to its(their) final destination
+ $(call LINUX_INSTALL_IMAGE,$(BINARIES_DIR))
# If there is a .ub file copy it to the final destination
test ! -f $(LINUX_IMAGE_PATH).ub || cp $(LINUX_IMAGE_PATH).ub $(BINARIES_DIR)
$(Q)touch $@