summaryrefslogtreecommitdiff
path: root/linux/linux.mk
diff options
context:
space:
mode:
authorIvo Slanina <ivo.slanina@gmail.com>2015-01-12 17:37:25 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-01-14 16:48:56 +0100
commitfc6ee4cadbe39fc5803f3d603b7ab4c3948b1bbc (patch)
tree1e61eb27b577905946437ebcec807a83fc153b42 /linux/linux.mk
parentefa0afe08ab0ef06277196d7a0acb9d75e5e9312 (diff)
linux/linux.mk: added https:// pattern for kernel patches
Patches located at https:// scheme URL were threated as directories, causing build failures. Fixed by adding https:// pattern. Signed-off-by: Ivo Slanina <ivo.slanina@gmail.com> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'linux/linux.mk')
-rw-r--r--linux/linux.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index 680521c55..d02b02b16 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -147,7 +147,7 @@ endif # BR2_LINUX_KERNEL_VMLINUX
define LINUX_DOWNLOAD_PATCHES
$(if $(LINUX_PATCHES),
@$(call MESSAGE,"Download additional patches"))
- $(foreach patch,$(filter ftp://% http://%,$(LINUX_PATCHES)),\
+ $(foreach patch,$(filter ftp://% http://% https://%,$(LINUX_PATCHES)),\
$(call DOWNLOAD,$(patch))$(sep))
endef
@@ -155,7 +155,7 @@ LINUX_POST_DOWNLOAD_HOOKS += LINUX_DOWNLOAD_PATCHES
define LINUX_APPLY_PATCHES
for p in $(LINUX_PATCHES) ; do \
- if echo $$p | grep -q -E "^ftp://|^http://" ; then \
+ if echo $$p | grep -q -E "^ftp://|^http://|^https://" ; then \
$(APPLY_PATCHES) $(@D) $(DL_DIR) `basename $$p` ; \
elif test -d $$p ; then \
$(APPLY_PATCHES) $(@D) $$p linux-\*.patch ; \