summaryrefslogtreecommitdiff
path: root/linux
diff options
context:
space:
mode:
authorNathan Ford <nford@westpond.com>2013-07-31 11:47:36 -0400
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-08-01 17:38:44 +0200
commit1ac04c321f892f6b93c0fb548b34be85f8426dc8 (patch)
tree4676ccb6fa74f102de45d63736ffaaddb6dc4f40 /linux
parentae86a3c5331f47c4a5093a5ea8f7e53408a6ea98 (diff)
Fix building initramfs kernel with appended dtb
The target for building the kernel with a cpio initramfs is not calling the append dtb commands, creating a final kernel image without an appended dtb. Instead it needs to call kernel make on the intermediate target, then call the append dtb commands to produce the final image as the primary kernel build target does. Signed-off-by: Nathan Ford <nford@westpond.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'linux')
-rw-r--r--linux/linux.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index 780d6d5e6..fc379ec49 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -313,6 +313,7 @@ $(LINUX_DIR)/.stamp_initramfs_rebuilt: $(LINUX_DIR)/.stamp_target_installed $(LI
@$(call MESSAGE,"Rebuilding kernel with initramfs")
# Build the kernel.
$(TARGET_MAKE_ENV) $(MAKE) $(LINUX_MAKE_FLAGS) -C $(@D) $(LINUX_IMAGE_NAME)
+ $(LINUX_APPEND_DTB)
# Copy the kernel image to its final destination
cp $(LINUX_IMAGE_PATH) $(BINARIES_DIR)
# If there is a .ub file copy it to the final destination