summaryrefslogtreecommitdiff
path: root/linux
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-10-18 23:05:01 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-12-20 15:23:07 +0100
commit24745cb4be748df7fea28195236fe60bb14bef0c (patch)
tree875d499ff5e7e77ef7eeb2c3cc5d15b3f4a2cbec /linux
parent55b80d3bb92ebfe334ba4b2ba980c45d1d2f1c05 (diff)
linux: only install the DTBs when not in appended DTB mode
When you're using the "appended DTB" mode, the Device Tree blob gets appended to your kernel image, so there is no point in installing both the DTB and the kernel image to the images or target directories, installing the kernel image itself is sufficient. Therefore, this commit disables the definition of LINUX_INSTALL_DTB when appended DTB is used. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'linux')
-rw-r--r--linux/linux.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index 5d6791a39..536e931ed 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -257,6 +257,7 @@ ifeq ($(BR2_LINUX_KERNEL_DTB_IS_SELF_BUILT),)
define LINUX_BUILD_DTB
$(LINUX_MAKE_ENV) $(MAKE) $(LINUX_MAKE_FLAGS) -C $(@D) $(KERNEL_DTBS)
endef
+ifeq ($(BR2_LINUX_KERNEL_APPENDED_DTB),)
define LINUX_INSTALL_DTB
# dtbs moved from arch/<ARCH>/boot to arch/<ARCH>/boot/dts since 3.8-rc1
cp $(addprefix \
@@ -264,8 +265,9 @@ define LINUX_INSTALL_DTB
$(addprefix $(KERNEL_ARCH_PATH)/boot/dts/,$(KERNEL_DTBS))),dts/),$(KERNEL_DTBS)) \
$(1)
endef
-endif
-endif
+endif # BR2_LINUX_KERNEL_APPENDED_DTB
+endif # BR2_LINUX_KERNEL_DTB_IS_SELF_BUILT
+endif # BR2_LINUX_KERNEL_DTS_SUPPORT
ifeq ($(BR2_LINUX_KERNEL_APPENDED_DTB),y)
# dtbs moved from arch/$ARCH/boot to arch/$ARCH/boot/dts since 3.8-rc1