summaryrefslogtreecommitdiff
path: root/linux
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-03-03 22:40:46 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-03-03 22:40:46 +0100
commit477c28cf1d637b224b819dd278103a05fb6f9dbb (patch)
tree0a931ae8375a5fb96bec27c1de2135e4f07c93b9 /linux
parentb4cacbf5b15db06132b5f401d39b4c8d4e79158e (diff)
linux: fix check of configuration file existence
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'linux')
-rw-r--r--linux/linux.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index ec7dfc39e..91a5fb8d8 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -166,9 +166,11 @@ else ifeq ($(BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG),y)
KERNEL_SOURCE_CONFIG = $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE))
endif
+ifeq ($(BR2_LINUX_KERNEL),y)
ifeq ($(wildcard $(KERNEL_SOURCE_CONFIG)),)
$(error Configuration file '$(KERNEL_SOURCE_CONFIG)' not found.)
endif
+endif
ifeq ($(call KCONFIG_GET_OPT,CONFIG_KERNEL_LZO,$(KERNEL_SOURCE_CONFIG)),y)
LINUX_DEPENDENCIES += host-lzop