summaryrefslogtreecommitdiff
path: root/linux
diff options
context:
space:
mode:
authorThomas De Schampheleire <patrickdepinguin+buildroot@gmail.com>2013-09-02 22:07:54 +0200
committerPeter Korsgaard <peter@korsgaard.com>2013-10-27 01:51:09 +0200
commit63ecded2e383b2bb7569e70f311580095b166e29 (patch)
treef5e4c4d61e3230bdae5d39a2001ea6ad4915b936 /linux
parentfbc2494a41bbdcc12b7242d06852892d2824db4d (diff)
linux: add support for custom Mercurial repository
Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'linux')
-rw-r--r--linux/Config.in32
-rw-r--r--linux/linux.mk5
2 files changed, 27 insertions, 10 deletions
diff --git a/linux/Config.in b/linux/Config.in
index 52291d8d7..a12102adf 100644
--- a/linux/Config.in
+++ b/linux/Config.in
@@ -52,6 +52,12 @@ config BR2_LINUX_KERNEL_CUSTOM_GIT
This option allows Buildroot to get the Linux kernel source
code from a Git repository.
+config BR2_LINUX_KERNEL_CUSTOM_HG
+ bool "Custom Mercurial repository"
+ help
+ This option allows Buildroot to get the Linux kernel source
+ code from a Mercurial repository.
+
endchoice
config BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE
@@ -62,24 +68,32 @@ config BR2_LINUX_KERNEL_CUSTOM_TARBALL_LOCATION
string "URL of custom kernel tarball"
depends on BR2_LINUX_KERNEL_CUSTOM_TARBALL
-config BR2_LINUX_KERNEL_CUSTOM_GIT_REPO_URL
- string "URL of custom Git repository"
- depends on BR2_LINUX_KERNEL_CUSTOM_GIT
+if BR2_LINUX_KERNEL_CUSTOM_GIT || BR2_LINUX_KERNEL_CUSTOM_HG
-config BR2_LINUX_KERNEL_CUSTOM_GIT_VERSION
- string "Custom Git version"
- depends on BR2_LINUX_KERNEL_CUSTOM_GIT
+config BR2_LINUX_KERNEL_CUSTOM_REPO_URL
+ string "URL of custom repository"
+ default BR2_LINUX_KERNEL_CUSTOM_GIT_REPO_URL \
+ if BR2_LINUX_KERNEL_CUSTOM_GIT_REPO_URL != "" # legacy
+
+config BR2_LINUX_KERNEL_CUSTOM_REPO_VERSION
+ string "Custom repository version"
+ default BR2_LINUX_KERNEL_CUSTOM_GIT_VERSION \
+ if BR2_LINUX_KERNEL_CUSTOM_GIT_VERSION != "" # legacy
help
- Git revision to use in the format used by git rev-parse,
+ Revision to use in the typical format used by Git/Mercurial
E.G. a sha id, a tag, branch, ..
+endif
+
config BR2_LINUX_KERNEL_VERSION
string
default "3.11.6" if BR2_LINUX_KERNEL_LATEST_VERSION
default BR2_DEFAULT_KERNEL_HEADERS if BR2_LINUX_KERNEL_SAME_AS_HEADERS
- default BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE if BR2_LINUX_KERNEL_CUSTOM_VERSION
+ default BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE \
+ if BR2_LINUX_KERNEL_CUSTOM_VERSION
default "custom" if BR2_LINUX_KERNEL_CUSTOM_TARBALL
- default BR2_LINUX_KERNEL_CUSTOM_GIT_VERSION if BR2_LINUX_KERNEL_CUSTOM_GIT
+ default BR2_LINUX_KERNEL_CUSTOM_REPO_VERSION \
+ if BR2_LINUX_KERNEL_CUSTOM_GIT || BR2_LINUX_KERNEL_CUSTOM_HG
#
# Patch selection
diff --git a/linux/linux.mk b/linux/linux.mk
index 901ce25c7..29a3fd3ac 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -14,8 +14,11 @@ LINUX_TARBALL = $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_TARBALL_LOCATION))
LINUX_SITE = $(patsubst %/,%,$(dir $(LINUX_TARBALL)))
LINUX_SOURCE = $(notdir $(LINUX_TARBALL))
else ifeq ($(BR2_LINUX_KERNEL_CUSTOM_GIT),y)
-LINUX_SITE = $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_GIT_REPO_URL))
+LINUX_SITE = $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_REPO_URL))
LINUX_SITE_METHOD = git
+else ifeq ($(BR2_LINUX_KERNEL_CUSTOM_HG),y)
+LINUX_SITE = $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_REPO_URL))
+LINUX_SITE_METHOD = hg
else
LINUX_SOURCE = linux-$(LINUX_VERSION).tar.xz
# In X.Y.Z, get X and Y. We replace dots and dashes by spaces in order