summaryrefslogtreecommitdiff
path: root/linux
diff options
context:
space:
mode:
authorThomas De Schampheleire <thomas.de.schampheleire@gmail.com>2016-01-15 09:47:35 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-01-16 14:04:57 +0100
commit77e7cdb5de94801982d0b0c37d26a12884ae1785 (patch)
treefd4bd88fbea3bf5d6f5fac40ebe42d61862e6cda /linux
parent2b291a074fa11539e47e76b790685ae8d96efb4c (diff)
perf: remove tests from target
The perf tool installed test files in output/target/usr/libexec/perf-core/tests/ which amounted to about 30+K. Since they are not needed for normal perf operation, remove them. Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'linux')
-rw-r--r--linux/linux-tool-perf.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/linux/linux-tool-perf.mk b/linux/linux-tool-perf.mk
index 0bd0ed1a1..07c351438 100644
--- a/linux/linux-tool-perf.mk
+++ b/linux/linux-tool-perf.mk
@@ -84,4 +84,5 @@ define PERF_INSTALL_TARGET_CMDS
$(TARGET_MAKE_ENV) $(MAKE1) $(PERF_MAKE_FLAGS) \
-C $(@D)/tools/perf O=$(@D)/tools/perf/ install
$(RM) -rf $(TARGET_DIR)/usr/libexec/perf-core/scripts/
+ $(RM) -rf $(TARGET_DIR)/usr/libexec/perf-core/tests/
endef