summaryrefslogtreecommitdiff
path: root/linux
diff options
context:
space:
mode:
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>2016-02-22 10:22:45 +0000
committerPeter Korsgaard <peter@korsgaard.com>2016-02-27 18:59:34 +0100
commit7f3a52f981274da2db17500a0908466d6aed83c7 (patch)
treef4586957fd1c24a4d71e3c6fbffca990c9a5850f /linux
parentb1a3c0abac0dadec8de0fc5f64c2237d340d6579 (diff)
perf: append endianness argument to ld when building for MIPS
We need to pass an argument to ld for setting the endianness when building it for MIPS architecture, otherwise the default one will always be used (which is big endian) and the compilation for little endian will always fail showing an error like this one: LD foo.o mips-linux-gnu-ld: foo.o: compiled for a little endian system and target is big endian Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'linux')
-rw-r--r--linux/linux-tool-perf.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/linux/linux-tool-perf.mk b/linux/linux-tool-perf.mk
index 07c351438..1070a1c09 100644
--- a/linux/linux-tool-perf.mk
+++ b/linux/linux-tool-perf.mk
@@ -27,6 +27,19 @@ PERF_MAKE_FLAGS = \
WERROR=0 \
ASCIIDOC=
+# We need to pass an argument to ld for setting the endianness when
+# building it for MIPS architecture, otherwise the default one will
+# always be used (which is big endian) and the compilation for little
+# endian will always fail showing an error like this one:
+# LD foo.o
+# mips-linux-gnu-ld: foo.o: compiled for a little endian system and
+# target is big endian
+ifeq ($(BR2_mips)$(BR2_mips64),y)
+PERF_MAKE_FLAGS += LD="$(TARGET_LD) -EB"
+else ifeq ($(BR2_mipsel)$(BR2_mips64el),y)
+PERF_MAKE_FLAGS += LD="$(TARGET_LD) -EL"
+endif
+
# The call to backtrace() function fails for ARC, because for some
# reason the unwinder from libgcc returns early. Thus the usage of
# backtrace() should be disabled in perf explicitly: at build time