summaryrefslogtreecommitdiff
path: root/linux
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2015-03-14 15:25:20 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-04-09 22:57:51 +0200
commit9bd541d3b2a0256d59bc84fb2d204401dcdedb8e (patch)
treefcc455678342d09fe2eb541d752203453f13bd16 /linux
parent53785a2c77e723c394197df68efb71d6938e1884 (diff)
linux: simplify adding new extensions
Curently, all three linux extensions follow the same layout: - test if the extension is enabled - add itself to linux' patch-dependencies - declare a macro, added as the pre-patch hook Except for the macro, all can be commonalised. Add a simple infrastructure for that: - extensions declare themselves in the list of extensions - extensions define their macro - the infra adds them to the patch-dependencies and pre-patch hooks as appropriate Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'linux')
-rw-r--r--linux/linux.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index 21eb3c996..deed073e5 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -327,6 +327,13 @@ endef
# included here *must* be in the same directory!
include $(sort $(wildcard linux/linux-ext-*.mk))
+LINUX_PATCH_DEPENDENCIES += $(foreach ext,$(LINUX_EXTENSIONS),\
+ $(if $(BR2_LINUX_KERNEL_EXT_$(call UPPERCASE,$(ext))),$(ext)))
+
+LINUX_PRE_PATCH_HOOKS += $(foreach ext,$(LINUX_EXTENSIONS),\
+ $(if $(BR2_LINUX_KERNEL_EXT_$(call UPPERCASE,$(ext))),\
+ $(call UPPERCASE,$(ext))_PREPARE_KERNEL))
+
$(eval $(kconfig-package))
# Support for rebuilding the kernel after the cpio archive has