summaryrefslogtreecommitdiff
path: root/linux
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2016-02-06 00:06:17 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-06 10:58:24 +0100
commite3e0583f9085eff4cd6d58460f4d044e895d6775 (patch)
treed1fd674693aa0fcb10e76927340a12929091d157 /linux
parent036ac26a29f636582ebdec99e02a88c8926fafc4 (diff)
linux: drop the option to use the same version as that of the headers
It is no longer meaningful, now that we have the option to use the kernel version for the linux headers, as it is more logical and more versatile. Add it to legacy. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Peter Korsgaard <peter@korsgaard.com> Cc: Arnout Vandecappelle <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'linux')
-rw-r--r--linux/Config.in13
-rw-r--r--linux/linux.mk3
2 files changed, 0 insertions, 16 deletions
diff --git a/linux/Config.in b/linux/Config.in
index 897119287..4d972e144 100644
--- a/linux/Config.in
+++ b/linux/Config.in
@@ -29,18 +29,6 @@ choice
config BR2_LINUX_KERNEL_LATEST_VERSION
bool "4.4.1"
-config BR2_LINUX_KERNEL_SAME_AS_HEADERS
- bool "Same as toolchain kernel headers"
- depends on !BR2_KERNEL_HEADERS_AS_KERNEL
- depends on BR2_TOOLCHAIN_BUILDROOT
- help
- This option will re-use the same kernel sources as the one
- that have been used for the kernel headers of the
- cross-compiling toolchain. Having the same version for the
- kernel running on the system and for the kernel headers is
- not a requirement, but using the same version allows to
- download only one tarball of the kernel sources.
-
config BR2_LINUX_KERNEL_CUSTOM_VERSION
bool "Custom version"
help
@@ -117,7 +105,6 @@ config BR2_LINUX_KERNEL_CUSTOM_LOCAL_PATH
config BR2_LINUX_KERNEL_VERSION
string
default "4.4.1" if BR2_LINUX_KERNEL_LATEST_VERSION
- default BR2_DEFAULT_KERNEL_HEADERS if BR2_LINUX_KERNEL_SAME_AS_HEADERS
default BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE \
if BR2_LINUX_KERNEL_CUSTOM_VERSION
default "custom" if BR2_LINUX_KERNEL_CUSTOM_TARBALL
diff --git a/linux/linux.mk b/linux/linux.mk
index c9986cd8a..578fea1a5 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -28,9 +28,6 @@ LINUX_SOURCE = linux-$(LINUX_VERSION).tar.xz
ifeq ($(BR2_LINUX_KERNEL_CUSTOM_VERSION),y)
BR_NO_CHECK_HASH_FOR += $(LINUX_SOURCE)
endif
-ifeq ($(BR2_LINUX_KERNEL_SAME_AS_HEADERS)$(BR2_KERNEL_HEADERS_VERSION),yy)
-BR_NO_CHECK_HASH_FOR += $(LINUX_SOURCE)
-endif
# In X.Y.Z, get X and Y. We replace dots and dashes by spaces in order
# to use the $(word) function. We support versions such as 4.0, 3.1,
# 2.6.32, 2.6.32-rc1, 3.0-rc6, etc.