summaryrefslogtreecommitdiff
path: root/package/bandwidthd
diff options
context:
space:
mode:
authorNathaniel Roach <nroach44@gmail.com>2014-10-19 18:10:29 +0800
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-10-19 13:22:46 +0200
commitaa500a49526a0d7e78fa8331b8bfaa4bac68e707 (patch)
tree1041699d3aa6b01a91b35659e15f9c36679241e1 /package/bandwidthd
parent3b4ec0c6a82fc853b00b2a720d0b945dcb2ea67e (diff)
bandwidthd: Version bump to handle indirect deps properly
Thanks to Romain Naour, Baruch Siach and Thomas Petazzoni, I've solved the build issues in certain cases for bandwidthd. The issue was that libpcap and libpng would depend on other libraries and upon testing for pcap/libpng the tests would fail due to not being able to find the other libraries. Bandwidthd's configure script now uses pkg-config for libpng and pcap-config for libpcap. pcap-config's path is specified in configure's arguments. Some other tweaks have been made including the layout and flow of configure.ac is a bit more logical, and the handling of postgres and sqlite has been tweaked. Finally, the test for X.Org has been removed. [Thomas: re-add Nathaniel SoB line, which was misplaced in the commit log, and therefore dropped when applying the patch.] Fixes: http://autobuild.buildroot.org/results/eb4/eb48acec37a7fd1714b267b105816bf0053d40e9/build-end.log Cc: Baruch Siach <baruch@tkos.co.il> Cc: Romain Naour <romain.naour@openwide.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Nathaniel Roach <nroach44@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/bandwidthd')
-rw-r--r--package/bandwidthd/bandwidthd.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/bandwidthd/bandwidthd.mk b/package/bandwidthd/bandwidthd.mk
index 7a2975fe4..ca991f992 100644
--- a/package/bandwidthd/bandwidthd.mk
+++ b/package/bandwidthd/bandwidthd.mk
@@ -4,18 +4,18 @@
#
################################################################################
-BANDWIDTHD_VERSION = v2.0.1-auto-r08
+BANDWIDTHD_VERSION = v2.0.1-auto-r11
BANDWIDTHD_SITE = $(call github,nroach44,bandwidthd,$(BANDWIDTHD_VERSION))
# Specified as "any version of the GPL that is current as of your
# download" by upstream.
BANDWIDTHD_LICENSE = GPL
-BANDWIDTHD_DEPENDENCIES = gd libpng libpcap
+BANDWIDTHD_DEPENDENCIES = gd libpng libpcap host-pkgconf
BANDWIDTHD_AUTORECONF = YES
-BANDWIDTHD_CONF_OPTS += --without-x
+BANDWIDTHD_CONF_OPTS += --with-pcap-config=$(STAGING_DIR)/usr/bin/pcap-config
ifeq ($(BR2_PACKAGE_BANDWIDTHD_POSTGRESQL),y)
BANDWIDTHD_DEPENDENCIES += postgresql