summaryrefslogtreecommitdiff
path: root/package/bdwgc
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2014-12-02 00:13:21 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-12-02 10:29:23 +0100
commite5ac570e13b453a4af7dd34568fd679e64c03720 (patch)
tree77ce1755ad95b96775b07c771ffdd0637744a4be /package/bdwgc
parentc7739084b9a171152c830a1bd168dbb2a2ab043d (diff)
package/bdwgc: only enable on supported architectures
bdwgc has support for a sub-set of the architectures we support. Since there is roughly a 50-50 split of our architectures that have support in bdwgc vs. those that do not, use a positive dependency logic, rather than a negative one. The list was constructed by visual inspection of the source code of bdwgc, but the header doing the check is, to say it politely, a bit difficult to read... So, some working archotectures may be missing. Users needing it may investigate if their architectures are indeed supported. Fixes; http://autobuild.buildroot.net/results/529/529b0b6dd47744c13f56e59a4c669a3f5d56530d/ Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Pedro Aguilar <paguilar@paguilar.org> Cc: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/bdwgc')
-rw-r--r--package/bdwgc/Config.in7
-rw-r--r--package/bdwgc/bdwgc.mk2
2 files changed, 9 insertions, 0 deletions
diff --git a/package/bdwgc/Config.in b/package/bdwgc/Config.in
index 9aa7c7dff..215c54d7e 100644
--- a/package/bdwgc/Config.in
+++ b/package/bdwgc/Config.in
@@ -1,5 +1,12 @@
+config BR2_PACKAGE_BDWGC_ARCH_SUPPORTS
+ default y
+ depends on BR2_arm || BR2_armeb || BR2_avr32 || BR2_i386 \
+ || BR2_mips || BR2_mipsel || BR2_powerpc || BR2_sh \
+ || BR2_sparc || BR2_x86_64
+
config BR2_PACKAGE_BDWGC
bool "bdwgc"
+ depends on BR2_PACKAGE_BDWGC_ARCH_SUPPORTS
depends on BR2_PACKAGE_LIBATOMIC_ARCH_SUPPORTS
select BR2_PACKAGE_LIBATOMIC_OPS
help
diff --git a/package/bdwgc/bdwgc.mk b/package/bdwgc/bdwgc.mk
index 3e6de1ac9..b40894735 100644
--- a/package/bdwgc/bdwgc.mk
+++ b/package/bdwgc/bdwgc.mk
@@ -4,6 +4,8 @@
#
################################################################################
+# When bumping the version number, check if the list of supported architectures
+# is still valid; see Config.log.
BDWGC_VERSION = 7.2f
BDWGC_SOURCE = gc-$(BDWGC_VERSION).tar.gz
BDWGC_SITE = http://www.hboehm.info/gc/gc_source