summaryrefslogtreecommitdiff
path: root/package/bitstream
diff options
context:
space:
mode:
authorJulian Scheel <julian@jusst.de>2015-10-18 14:34:10 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-10-18 15:53:05 +0200
commit29e875313c18732b6677d0d0610ad5977896da4b (patch)
tree4ebc99971499227ce818fd31a6e2c6736d389695 /package/bitstream
parent60be5da7c9bb92309627c58e81623da4268d1e07 (diff)
bitstream: new package
BiTStream is a set of headers to ease processing of mpeg ts streams. It is used by dvblast. [Thomas: - add missing hash file. - add missing BITSTREAM_LICENSE_FILES information. - rewrap Config.in help text. - use lowercase name for the package in the comment header in bitstream.mk.] Signed-off-by: Julian Scheel <julian@jusst.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/bitstream')
-rw-r--r--package/bitstream/Config.in8
-rw-r--r--package/bitstream/bitstream.hash4
-rw-r--r--package/bitstream/bitstream.mk21
3 files changed, 33 insertions, 0 deletions
diff --git a/package/bitstream/Config.in b/package/bitstream/Config.in
new file mode 100644
index 000000000..9d967a0f5
--- /dev/null
+++ b/package/bitstream/Config.in
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_BITSTREAM
+ bool "bitstream"
+ help
+ biTStream is a set of C headers allowing a simpler access to
+ binary structures such as specified by MPEG, DVB, IETF,
+ SMPTE, IEEE, SCTE, etc.
+
+ http://www.videolan.org/developers/bitstream.html
diff --git a/package/bitstream/bitstream.hash b/package/bitstream/bitstream.hash
new file mode 100644
index 000000000..7a3b7f863
--- /dev/null
+++ b/package/bitstream/bitstream.hash
@@ -0,0 +1,4 @@
+# from https://get.videolan.org/bitstream/1.1/bitstream-1.1.tar.bz2.md5
+md5 88e6e786242196b4d73a5b6075aeb1a2 bitstream-1.1.tar.bz2
+# locally calculated
+sha256 90b65f619895d31e652386d5d7d2d2d62cccd44383c1fac9145d659013a2de9e bitstream-1.1.tar.bz2
diff --git a/package/bitstream/bitstream.mk b/package/bitstream/bitstream.mk
new file mode 100644
index 000000000..a76c3c44b
--- /dev/null
+++ b/package/bitstream/bitstream.mk
@@ -0,0 +1,21 @@
+################################################################################
+#
+# bitstream
+#
+################################################################################
+
+BITSTREAM_VERSION = 1.1
+BITSTREAM_SOURCE = bitstream-$(BITSTREAM_VERSION).tar.bz2
+BITSTREAM_SITE = https://get.videolan.org/bitstream/$(BITSTREAM_VERSION)
+BITSTREAM_LICENSE = MIT
+BITSTREAM_LICENSE_FILES = COPYING
+
+# package consists of header files only
+BITSTREAM_INSTALL_STAGING = YES
+BITSTREAM_INSTALL_TARGET = NO
+
+define BITSTREAM_INSTALL_STAGING_CMDS
+ $(MAKE) -C $(@D) DESTDIR=$(STAGING_DIR) PREFIX=/usr install
+endef
+
+$(eval $(generic-package))