summaryrefslogtreecommitdiff
path: root/package/cannelloni
diff options
context:
space:
mode:
authorYegor Yefremov <yegorslists@googlemail.com>2016-04-18 12:06:58 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-04-18 13:34:35 +0200
commit85f2e13c637bbc05a428436ef000b5531505b756 (patch)
tree1450d8fdd5796784ca19a1eb3f4d4ea9dca04bfe /package/cannelloni
parentac031cfb976980dd68dfb52e7b610b4e6e27fe17 (diff)
cannelloni: make SCTP support optional
Since version 20160414 SCTP support is optional. Introduce an automatic optional dependency for this protocol. Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/cannelloni')
-rw-r--r--package/cannelloni/Config.in1
-rw-r--r--package/cannelloni/cannelloni.mk8
2 files changed, 7 insertions, 2 deletions
diff --git a/package/cannelloni/Config.in b/package/cannelloni/Config.in
index 8f3e88830..e137e60c6 100644
--- a/package/cannelloni/Config.in
+++ b/package/cannelloni/Config.in
@@ -5,7 +5,6 @@ config BR2_PACKAGE_CANNELLONI
depends on BR2_USE_MMU # lksctp-tools
depends on BR2_TOOLCHAIN_HAS_THREADS # lksctp-tools
depends on !BR2_STATIC_LIBS # lksctp-tools
- select BR2_PACKAGE_LKSCTP_TOOLS
help
A SocketCAN over Ethernet tunnel. The tunnel supports both
UDP and SCTP protocols.
diff --git a/package/cannelloni/cannelloni.mk b/package/cannelloni/cannelloni.mk
index 680e09a00..fffdb4ba9 100644
--- a/package/cannelloni/cannelloni.mk
+++ b/package/cannelloni/cannelloni.mk
@@ -8,6 +8,12 @@ CANNELLONI_VERSION = 20160414
CANNELLONI_SITE = $(call github,mguentner,cannelloni,$(CANNELLONI_VERSION))
CANNELLONI_LICENSE = GPLv2
CANNELLONI_LICENSE_FILES = gpl-2.0.txt
-CANNELLONI_DEPENDENCIES = lksctp-tools
+
+ifeq ($(BR2_PACKAGE_LKSCTP_TOOLS),y)
+CANNELLONI_CONF_OPTS += -DSCTP_SUPPORT=ON
+CANNELLONI_DEPENDENCIES += lksctp-tools
+else
+CANNELLONI_CONF_OPTS += -DSCTP_SUPPORT=OFF
+endif
$(eval $(cmake-package))