summaryrefslogtreecommitdiff
path: root/package/dhcpcd
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-10-21 22:27:07 +0200
committerPeter Korsgaard <peter@korsgaard.com>2014-11-07 00:04:10 +0100
commit04a586ecb31cde9db1eceef9b64e2f5f214a9ac6 (patch)
tree73ea0bd033b468abd023c6173530c46d20cdb099 /package/dhcpcd
parent29f680644ac722eea39acd79702ffeb564aa4ee6 (diff)
dhcpcd: do not pass --target option
dhcpcd is using $(BR2_GCC_TARGET_ARCH) as the value of its --target option. However, depending on the architecture, this value might be empty. After inspecting the dhcpcd configure script, it turns out that in fact the --target option has the following semantic: --target=TARGET configure for building compilers for TARGET [HOST] So it is very much like the --target option of regular, autoconf-based, configure scripts. Since dhcpcd is not a compiler, passing --target is pointless. Moreover, as long as --os=linux is passed, passing --host or --target is completely ignored by the configure script. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/dhcpcd')
-rw-r--r--package/dhcpcd/dhcpcd.mk1
1 files changed, 0 insertions, 1 deletions
diff --git a/package/dhcpcd/dhcpcd.mk b/package/dhcpcd/dhcpcd.mk
index f4b821af2..3bb7a135f 100644
--- a/package/dhcpcd/dhcpcd.mk
+++ b/package/dhcpcd/dhcpcd.mk
@@ -25,7 +25,6 @@ endif
define DHCPCD_CONFIGURE_CMDS
(cd $(@D); \
$(TARGET_CONFIGURE_OPTS) ./configure \
- --target=$(BR2_GCC_TARGET_ARCH) \
--os=linux \
$(DHCPCD_CONFIG_OPTS) )
endef