summaryrefslogtreecommitdiff
path: root/package/dtc
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-08-04 18:19:18 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-08-04 18:19:18 +0200
commit8a69fa777940be73d5224cb2b8c702bef5ba8074 (patch)
treec94b96105913738a7161fe10d2ef1be837ebf0da /package/dtc
parentba865a4c92454e75340908e2e0dec38180fba130 (diff)
Revert "dtc: install libfdt library and headers for host variant"
This reverts commit 5ca9b7cf66941a66cff736aadaf8a31afe55f964. Installing dtc headers in $(HOST_DIR) causes some build failures of host-uboot-tools due to a conflicting libfdt.h header. The possible solution to solve this problem, based on -isystem, has been reverted has it was causing too many issues that we didn't want to solve so close to cutting 2016.08-rc1. Since the headers of libfdt for the host are currently not needed for any package in the Buildroot tree, it is easier and safer to just revert this patch. Fixes: http://autobuild.buildroot.net/results/9fba77f4080bf6bc26e341f3f383cdba26c0e14f/ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/dtc')
-rw-r--r--package/dtc/dtc.mk4
1 files changed, 1 insertions, 3 deletions
diff --git a/package/dtc/dtc.mk b/package/dtc/dtc.mk
index febd5920c..8fdcdbed7 100644
--- a/package/dtc/dtc.mk
+++ b/package/dtc/dtc.mk
@@ -51,9 +51,7 @@ define HOST_DTC_BUILD_CMDS
endef
define HOST_DTC_INSTALL_CMDS
- $(MAKE) -C $(@D) PREFIX=$(HOST_DIR)/usr install-bin install-lib \
- install-includes
-
+ $(MAKE) -C $(@D) PREFIX=$(HOST_DIR)/usr install-bin
endef
$(eval $(generic-package))