summaryrefslogtreecommitdiff
path: root/package/flannel
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-07-24 16:43:46 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-07-24 21:59:24 +0200
commit80634e30615e276481f30127659106031712b428 (patch)
tree9d320a2dde12b2c84333a650d135ae664b3ff892 /package/flannel
parent98cc1cbeb69e894723c59ac6d510d5e66d525ea4 (diff)
flannel: pass -extldflags '-static' on when BR2_STATIC_LIBS=y
There is no reason to link Go binaries statically, unless when BR2_STATIC_LIBS=y. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Tested-by: Christian Stewart <christian@paral.in> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/flannel')
-rw-r--r--package/flannel/flannel.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/flannel/flannel.mk b/package/flannel/flannel.mk
index b5f61a01b..18c0af160 100644
--- a/package/flannel/flannel.mk
+++ b/package/flannel/flannel.mk
@@ -21,7 +21,10 @@ FLANNEL_MAKE_ENV = \
FLANNEL_GLDFLAGS = \
-X github.com/coreos/flannel/version.Version=$(FLANNEL_VERSION) \
- -extldflags '-static'
+
+ifeq ($(BR2_STATIC_LIBS),y)
+FLANNEL_GLDFLAGS += -extldflags '-static'
+endif
define FLANNEL_CONFIGURE_CMDS
# Put sources at prescribed GOPATH location.